3

My admin share C$ has been removed causing our server-managed security (Sophos Endpoint Security and Control) to stop updating this workstation because it is unable to create local tasks.

I've searched for two days now; lots of stuff about disabling C$ or allowing network access via a Registry edit but nothing about restoring a missing "default admin share C$".

I can recreate C$ from the MMC but it's removed after a reboot.

System is Windows 7 Pro 64-bit on a domain.

0

Have you tried this KB article? It's for Windows NT 4, but the symptoms and fix steps seem like they might still work on a modern Windows.

The symptom it lists is

When you use Server Manager or the "NET USE /D" command to stop sharing a shared, administrative folder (such as ADMIN$ or C$), users are unable to access files or folders on the shared location.

So it seems like the C$ share should be covered by the advice. One of the suggested fixes is

Type the following commands from a command prompt: net share sharename$

So in your case, I'm guessing you would type

net share c$

Apologies for not trying myself - I don't have a test machine handy at the moment.

  • Hi dsolimano, from a reboot C$ is missing from the share list under Computer Management (local), Shares & running "net share C$" in a administrator command window yields "This shared recourse does not exist." – woodelf Dec 14 '12 at 0:02
  • Using the Create A Shared Folder Wizard to recreate C$ with "Administrators have full access; other have read-only access" & running net share C$ again the command completes successfully. Obviously I have to reboot & test to see if Sophos can now push down the updates... will get back with the results. Thanks Nick – woodelf Dec 14 '12 at 0:11
  • No luck the C$ share is gone after a reboot - the culprit appears to be Tuneup Utilitis which I tried once before uninstalling. It appears to have removed C$ share as a security risk. Now the question is how to restore the C$ share? – woodelf Dec 14 '12 at 1:42
0

Usually rebooting should fix the problem, if someone remove it.

if its not recreated, Check this KB article to see if the windows share autocreate settings where changed.

If all fails, try restarting the server service and check the event viewer for errors, it should say something

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.