I recently bought parts from Amazon to build an embedded PC, and have assembled everything. I have:

The motherboard gets a light (on the motherboard, not on the Pico-PSU) when I plug it into the power adapter. Furthermore, I see the power switch light come on when I press the power button. However, the display doesn't turn on, and it doesn't seem that the PC is actually turned on.

Since I'm seeing these lights, I know that the motherboard is getting power. Furthermore, the display VGA port is embedded into the motherboard, so that's not the issue.

I'm just trying to figure out what COULD be the issue aside from a faulty motherboard.

I have a diagram of the D2500HN motherboard which labels everything, and have ensured that the power LED as well as the On/Off cables are plugged into the right spots, although to be sure I've tried flipping these two cables around, and also plugging 1 cable into the other cable's spot & vice-versa.

Is there anything else you folks think I may be missing, or anything else I can do to try to troubleshoot this issue before sending the motherboard back?


Have you tried to boot with no memory? Maybe the RAM is hanging it, test every possible situation. By this, I mean remove all but one stick, test, then add another, test, etc.

  • 1
    The RAM wasn't the issue, but the lack-thereof WAS the issue. I reseated both DIMMs tonight, and realized that neither of them were in all of the way. After reseating them, this thing is working like a charm. You didn't REALLY get the solution to my problem right, but you got me going down the right path. Thanks!
    – David W
    Dec 15 '12 at 0:28
  • you're welcome! good to know u solved it Dec 17 '12 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.