I have installed Windows 8 on a machine with an Asus M4A88TD-M/USB3 motherboard which has an ALC892 sound chip. I can't seem to get the sound chip to work correctly. I've installed the latest driver 2.70 and the audio devices in the device manager look like this:

device manager

The upper device uses the Realtek driver but the two lower once use a Microsoft default driver. I've tried to install drivers for the two lower devices manually but there are no compatible ones among the downloaded Realtek drivers (At least Windows claims so).

Anyway now the sound settings look like this:


You can see that the Realtek device is missing. Also the Realtek Soundmanager doesn't seem to work correctly:


The onboard sound is activated in BIOS and works just fine on the Ubuntu I've installed in dual boot.

Does anyone have an idea how to solve this?

  • Remove asus drivers - auto detect in w8 works fine – user180307 Dec 14 '12 at 14:55
  • No, it doesn't. Thats why I installed the Asus/Realtek drivers in the first place. – André Stannek Dec 14 '12 at 14:56
  • Are you running "Realtek Audio Driver V6.0.1.6699 for Windows 8 32bit & 64bit." drivers from here? asus.com/Motherboards/AMD_AM3/M4A88TDMUSB3/#download – Mark Allen Dec 15 '12 at 3:33
  • The download page I visited looked different but the file is the same. It was the first one I've tried. After that I tried the 2.70 directly from Realtek. – André Stannek Dec 15 '12 at 10:18

I found the solution. I was kind of stupid though. I tried to setup the sound properties using remote desktop all the time. What I didn't know was, that it obfuscates the local device and creates it's own device to pass all sound through to the client. That's why the two devices are called remote audio. I noticed it when I tried connecting with another RDP Client where sound was disabled. Suddenly the two device were gone and the Sound options showed that no device was available.

Used a mouse and a keyboard locally now and it seems that everything was fine all along :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.