17

I want my computer to start uTorrent at 4 o'clock in the morning, when I'm asleep. But the computer is a bit noisy so I put it to sleep mode every time I go to bed.

I've tried creating a task in Task Scheduler with this parameters:

  • Run whether user is logged in or not
  • Daily At 4:00 every day
  • Start a program "C:\Program Files\uTorrent\uTorrent.exe"
  • Wake the computer to run this task

I've tried to change the time to run to make sure the computer wakes up and runs uTorrent. But it doesn't.

What am I doing wrong? Maybe I've lost something?

  • @valya; did deddebme's solution work for you? If so you should accept his answer. – RJFalconer Jan 17 '10 at 13:54
  • no, It didn't. I yield – valya Jan 17 '10 at 14:12
  • I noticed that powercfg -waketimers never shows wake events scheduled by the Task Scheduler. Even though it says "There are no active wake timers in the system." everything was actually working just fine. – Nic Dec 19 '12 at 19:27
28

I had the same problem. In the end it was a stupid default configuration in the Windows 7 power plan options. Go to "Control Panel -> All Control Panel Items -> Power Options -> Edit Plan Settings" for the power plan u are using. Then select "Change advanced power settings". Next go to "Sleep -> Allow wake timers" and enable them there. At least in my case they were by default disabled. IMHO kinda stupid especially if one can schedule tasks that are supposed to wake up without getting a warning.

  • I had the exact same problem. Black_Jet's answer worked for me. – Rob3C Mar 5 '10 at 11:35
  • 2
    This does not work for me :( – Andrestand Jun 28 '17 at 8:44
  • It seems I had them disabled by default as well. This is really stupid design choice and hard to pin down. – moondra Jan 24 '18 at 17:25
5

Use WakeUpOnStandBy. An excellent freeware utility that does exactly that, and then some more if you need it.

enter image description here

  • either this program doesn't work on w7 or there is something wrong with me or my computer (a new HP notebook) – valya Oct 6 '09 at 23:02
  • Could you be more specific please? I have been using it successfully since I upgraded from XP to Win 7 (and before that of course). Could you also provide your HP model? The one requirement for it to work is that your computer supports ACPI. – A Dwarf Oct 6 '09 at 23:19
  • HP Compaq 615. Windows 7 Ultimate (not RC or something). I've checked BIOS but there's nothing about ACPI – valya Oct 7 '09 at 10:12
5

If you are putting your computer to sleep with the commonly used batch script command Rundll32.exe Powrprof.dll,SetSuspendState Sleep then the scheduled task will not be able to wake the computer from sleep, this is due to what appears to be a bug in Rundll32.exe.

Credit goes to Techie007L's post on the microsoft forums for discovering this and proposing a solution. Instead of calling Rundll32.exe in your batch script you download an alternative tool and call that instead.

Unfortunately, after all the features it has, the Microsoft shutdown command is missing the standby feature! So, it you want to put your computer to sleep via command line, you'll need to install a more capable tool before you can use the last command above:

  1. Download Sysinternals PsTools.
  2. The download should be a ZIP file. Open it and copy PsShutdown.exe to your > desktop.
  3. On your desktop, right-click PsShutdown.exe and click Copy. Right-click it > again and click Properties.
  4. Tick Unblock and click [OK].
  5. Open File Explorer, navigate to "C:\Windows", scroll down, right-click the > system32 folder and click Paste.
  6. To enter standby, you can now use this command: psshutdown -d -t 0
2

How about you set the auto power on timer in BIOS?

It should be under the power management section of the BIOS, named something like "Wake by RTC etc". You may see the below example BIOS screenshot:

alt text

  • where do I? found nothing in bios – valya Oct 7 '09 at 10:12
  • see my edited answer – deddebme Oct 9 '09 at 14:59
0

Make sure you follow everything in this article accurately. I've also had an issue with accounts that have no password before. If your account does not have a password, try giving it one and see if the results differ, I'm pretty sure you need a password to run a scheduled task. If it already has one, make sure it was typed correctly. You should be able to see why the last task didn't run successfully in task scheduler.

  • Oh, I was hoping it checks the password then I'm entering it :) There is nothing interesting in the article, but I'm going to check the password, thanks – valya Oct 6 '09 at 22:45
  • check task scheduler itself, it should tell you why the last task didn't run. – John T Oct 6 '09 at 22:45
  • checked the pass: everything is ok. no it doesn't (or I don't know where to look). still not waking! – valya Oct 6 '09 at 23:02
0

You might have to enable hybrid sleep in order for it to work. The quickest way to do this is to run powercfg.exe -H ON(see technet) from an elevated command prompt.

  • 2
    How about adding the details as to how to do this? – slm Dec 22 '12 at 23:30
  • This does not work for me :( – Andrestand Jun 28 '17 at 8:44
0

If the task wakes up the computer but gets stuck in the login screen go the group policy. Add your username into this:

Computer Configuration-->Policies-->Windows Settings-->Security Settings-->Local Policies-->User Rights Assignment--> allow logon locally

Actually, the task does not need to be logged to work. Simply uncheck the task the option "run whether the user is logged or not". The task will just do whatever you will ask (eg. play a sound using WMP) behind the logging screen. (If you really need to log on edit the group policies).

0

if its a laptop you need to enable timers in the sleep category of your power options.

Select the power options from the menu Select the current power option select change plan settings select change advanced power settings click on the 'plus' next to 'sleep' click on the 'plus' next to 'allow wake timers' Seletc battery and set to enable select on power and set to enable repeat for other power plans then this should work.

I set the task scheduler to run a batch file that contains the text 'echo hello' without the single quotes and it started my laptop up.

hope this works for you all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.