I am trying to install Arch Linux on my Acer Aspire 4830tg, but I keep running into problems.

Some background knowledge: I am trying to install Arch off a USB stick and I got the ISO image using bittorrent. I am also trying to install it alongside of Windows 8 (which is already installed).

When I boot into Arch linux I get this error:

:: Mounting '/dev/disk/by-label/ARCH_201212' to 'run/archiso/bootmnt'
Waiting 30 seconds for device /dev/disk/by-label/ARCH_201212 ...
ERROR: '/dev/disk/by-label/ARCH_201212' device did not show up after 30 seconds...
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off

I know that it will work if I run it on a virtual machine but whenever I try to install it on my laptop I keep getting this error. And since you can't register for the Arch forums without an Arch terminal to run their captcha command I can't ask this on their forums.

  • 2
    You don't need an Arch terminal to run the captcha. – Squeezy Jun 24 '13 at 22:11

I got this error using an ISO to USB program on Windows.

The problem was that the filesystem label did not change to 'ARCH_201306' when the program formatted the USB drive. In my case, it was still labelled 'PENDRIVE'.

This is why '/dev/disk/by-label/ARCH_201306' never shows up. The USB drive has the wrong name.

Solution is to rename the USB drive to 'ARCH_201306' (or similar name based on the release date).

  • 1
    Cheers! I had this using UNetbootin for Mac. – Joël Sep 29 '16 at 7:39
  • You can check out Arch Linux' release dates here. – Matthias Braun Oct 2 '16 at 13:32

According to this page, the problem is because you are booting from a USB drive. Try the solution suggested there, type this command at the prompt (you may have to type exit or hit enter first to get a prompt):

ln -s /dev/sdb1 /dev/archiso

That assumes that your USB drive is detected as /dev/sdb. To find out if it is the case, run:

cat /proc/scsi/scsi

Other solutions are also suggested on the thread I linked to.

  • 1
    after successfully making the symlink (at this time the command that was needed was something like (ln -sf /dev/disk/by-label/MYWRONGLYNAMEDDRIVE /dev/disk/by-label/ARCH_201307) just exit the prompt – tjb Jul 4 '13 at 14:55
  • This doesn't work for me because it's still looking for the disk by-label that doesn't exist. – leetNightshade Feb 6 '17 at 4:29

First, check this post: https://bbs.archlinux.org/viewtopic.php?id=142473

They mention something about specifying the wrong device when creating the disk. In particular, maybe you used /dev/sdx1 instead of /dev/sdx

If that doesn't help, I suggest you try the two options to create the live USB they give in their wiki: https://wiki.archlinux.org/index.php/USB_Installation_Media

Then, if it keeps failing, try Unetbootin to generate the bootable USB.

If you still can't make it work, try either using ArchBang (fastest option), the Netboot image, or an older snapshot of Arch (not too old, or it won't have systemd).

Finally, if all of the above failed, cry yourself to sleep and install another distribution when you wake up :)

  • Unfortunately, there is no good method for dealing with cross-site duplicate questions. So instead of linking to your answer on U&L, it's better to just post the same thing here. No this isn't perfect, but it's the best we can do. – terdon Feb 6 '17 at 10:07

I encountered this problem because I rushed into installing Arch Linux via UNetbootin. This is not recommended since UNetbootin overwrites syslinux.cfg on the USB stick.

To make Arch Linux boot after UNetbootin copied the installation files to the USB stick, you have to edit syslinux.cfg:

default menu.c32
prompt 0
menu title Archlinux Installer
timeout 100

label unetbootindefault
menu label Archlinux_x86_64
kernel /arch/boot/x86_64/vmlinuz
append initrd=/arch/boot/x86_64/archiso.img archisodevice=/dev/sdb1 ../../

label ubnentry0
menu label Archlinux_i686
kernel /arch/boot/i686/vmlinuz
append initrd=/arch/boot/i686/archiso.img archisodevice=/dev/sdb1 ../../
  • Didn't help me in trying to install Apricity though the same files exist, so I thought this would work. – leetNightshade Feb 6 '17 at 4:35

If used Unetbootin, try pressing Tab on the boot dialog for the options and add archisolabel=LABEL_OF_YOUR_USB_DRIVE on the /ubkern command line.

For me, even having the right USB label already as ARCH_yyyymm I had to enter this information.

Tip from here.

  • My boot options already look fine, still have the issue. – leetNightshade Feb 6 '17 at 4:26

Though @razzintown's answer is correct, you can create a symbolic link if the error occurred during installation.

ln -s /dev/sdb /dev/disk/by-label/ARCH_201609

Where sdb is you usb disk and ARCH_201609 is the desired mount point label the installation is asking for.

It worked for me, hope ti solves your problem too.


Quick way from here:

mv /dev/disk/by-label/THE_RIGHT_LABEL_FOUND_WITH_TAB /dev/disk/by-label/THE_LABEL_INSTALLATION_WANTS

Of course replace capitalized words accordingly.


I just wound up installing it with a CD. It was much easier and it didn't have any problems mounting. I would also recommend using the Bittorrent download link, since it hash checks it as it is downloading, verses using a http download unless you are going to actually run the hash check when its done downloading.

Thanks for all the suggestions everyone.

  • 5
    I downvoted this "answer". You received two actual answers to your question. Just because you didn't like them doesn't mean you can change the question and make up your own answer. – darkAsPitch May 10 '13 at 18:29
  • @darkAsPitch how was this question changed? – James Mertz Jun 24 '13 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.