I am having Dell Inspiron N5520 laptop. Am confusing with graphics details. When type dxdiag, the graphics properties is shown with Intel HD graphics 4000. When i Search in device manager under network adaptor it has AMD Radeon 7670m and Intel HD graphics 4000.

So why in dxdiag doesnt shown up the AMD graphics card. What should i do to make both graphics card active.

Although both are in enable mode now.

  • pls feel free to ask me if you are unclear – Ramachandran Dec 15 '12 at 18:02
  • It's not unclear, it's that you apparently didn't try to research it at all. It's a "feature" of your notebook, that presumably you bought. :) As well, you may want to form your question so that it's not asking "Why" things are happening, but rather more like "I'm trying to accomplish X, I'm getting stuck at Y, I've tried Z. What can I do to get past Y so I can complete X?". – Ƭᴇcʜιᴇ007 Dec 15 '12 at 18:13

I found a post by a Dell employee at Dell's support forum that explains it very well:

Dell Inspiron n5520 comes with multiple video cards. You will not be able to know which GPU is active using the ‘Catalyst Control Center’. This feature has not been provided by AMD.

In Muxless hardware design, the switchable graphics will use appropriate video card to assigned application from the catalyst control center and process the graphics of the application and give the output through the Intel’s integrated video card so using any application on windows you will not be able to see the discrete video card.

Therefore, when you are using graphic intense programs, (Example: Playing games, video editing, photo editing) the discrete graphic card turns active.

However, during normal usage, if you are viewing applications like office, power point or word documents the integrated graphic card turns active.

The same post then goes on to explain that you have some control over it via the usual ATI/AMD Catalyst Control Center software. It also offers some remedies for situations where options may not appear in the CCC.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.