In windows, CPUz provides info about memory timings. Is it possible to view that in linux? Is there any app that can show me the memory timings of the RAM currently installed in my system?

EDIT: I want to know the CAS latency. CPUz screenshot:

enter image description here


4 Answers 4


Memtest will show you the timings and I found on the ubuntuforums that i2c-tools will give you what you're looking for with these commands:

sudo modprobe eeprom    

You can get information about the memory with:

lshw -C memory

In particular, you can get the clock speed and latency with:

lshw -C memory | grep clock
  • 6
    I get 1.9 ns. How do I translate that to CAS latency value, if possible?
    – Papul
    Dec 15, 2012 at 18:58
  • 2
    If you are going to need more information, you should use i2c-tools instead.
    – balkian
    Dec 15, 2012 at 19:13
  • 2
    That 1.9 ns is the clock interval, not the latency. This tool is reading DMI, you'd need something that reads SPD. Nov 28, 2013 at 7:11
  • 2
    The tool actually reports memory capabilities, not the effective clock. For instance, on my hardware (motherboard supports memory clock up to 1600 MHz) it reports: clock: 2133MHz (0.5ns) (which is the maximum speed my DDR modules can operate at, provided they're plugged in a more modern MB).
    – Bass
    Feb 18, 2016 at 9:46
  • Does this command works under virtual machine? I got nothing after executing the command
    – Frank Liu
    Sep 24, 2018 at 7:30

This worked for me:

sudo aptitude install i2c-tools
sudo modprobe eeprom
sudo modprobe at24
sudo modprobe i2c-i801
sudo modprobe i2c-amd-mp2-pci
sudo modprobe ee1004

decode-dimms needs the correct module to be loaded to be able to read the DIMMs. It is unclear to me exactly which one worked for me, but I guess it depends on the chipset in your machine.

  • Can you please add a source/ give explanation of what those commands do? Your answer appeared on the Low Quality Posts queue.
    – CaldeiraG
    Nov 6, 2019 at 12:55
sudo apt-get install i2c-tools
sudo modprobe eeprom

# lots of output, including:
Decoding EEPROM: /sys/bus/i2c/drivers/eeprom/0-0050
Guessing DIMM is in                              bank 1
---=== Timings at Standard Speeds ===---
tCL-tRCD-tRP-tRAS as DDR3-1600                   11-11-11-28
tCL-tRCD-tRP-tRAS as DDR3-1333                   9-9-9-24
tCL-tRCD-tRP-tRAS as DDR3-1066                   7-7-7-19
tCL-tRCD-tRP-tRAS as DDR3-800                    6-6-6-14


Note: this is a working (on my system) guide made from analogous QA https://unix.stackexchange.com/questions/92037/how-to-view-rams-spd-timings-table, mostly info was mentioned here already, but "Ubuntu" link is not working, so I decided to write my own answer.

Some "discovery mission" where it is probably all started: http://www.richud.com/wiki/Ubuntu_See_Live_RAM_Timings_Decode_DIMMS

$ decode-dimms

Command 'decode-dimms' not found, but can be installed with:

sudo apt install i2c-tools

$sudo apt-get install i2c-tools
$ decode-dimms
No EEPROM found, try loading the eeprom or at24 module

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .