I had a computer that was working fine for over a year, then suddenly it started to shut off, it got so bad that I press the power button and in around 30 seconds while booting Windows it would shut off, then 20 seconds, then 10, then it refused to start all together.

So I bought a new PSU (850 W Thermaltake, the old one was a 550 W Corsair) thinking that was the problem. I fitted the new PSU now and it's the same thing - I press the power button and my fans start for a split second (they have LED lights on them, so the lights come on) and then everything goes off again.

I thought maybe it was my power button that was loose on my computer. Luckily I had another chassis nearby so I disconnected the power switch from the old one and put in the switch from the new chassis. But when I pressed the power on the new chassis, it's same thing, it blinks for a split second and turns off again.

Double checked connections from the PSU to the CPU power as well as motherboard power, it's tight. It's pretty unlikely both the PSUs have the same exact problem so I am lost.

Any suggestions?

  • Have you checked that the heat sink and fan hasn't come loose from your CPU? It could be shutting down as quickly as it overheats. Commented Dec 15, 2012 at 22:06
  • Does not look like it, seems to be on pretty hard. Even then wont it take more than a second? This is going off in milliseconds...
    – Ryan
    Commented Dec 15, 2012 at 22:09
  • Do you have any bulging capacitors? If you are not getting a POST, it could be that, or your motherboard got fried.
    – Colum
    Commented Dec 15, 2012 at 22:12
  • My mobo is a p67 Extreme 7, all metal capacitors so had to google to see how the look when they bulge... as far as I can see, no bulge. But something mew, now when I press the power not even the fans move slightly, absolutely no effect :(
    – Ryan
    Commented Dec 15, 2012 at 22:21
  • Cab't find anything, I guess the MOBO is fried as my sis says she smelled something burning a few days back and it smelled like burning wires... :(
    – Ryan
    Commented Dec 15, 2012 at 22:35

2 Answers 2


How about checking for other loose connections?

Also, try disconnecting as much as you can (but still having a potentially working PC).

Remove all but one RAM chip. Play with different combinations etc.

It could be overheating, so check that all colling systems, fans, heat sinks are ok.

If the PC works with hardware removed, then add components one by one until you find a fault.

  • Took out 3 of 4 RAM sticks... will continue disconnecting...
    – Ryan
    Commented Dec 15, 2012 at 22:21
  • 1
    Nothing found, but your answer is the only one and makes sense so will pick it...
    – Ryan
    Commented Dec 15, 2012 at 22:36

I have the same problem and I discovered that it was the cpu, doesn't boot with different motherboards, different RAM, different RAM-slots, no gpu and so on. Also tried with nothing connected except motherboard and cpu power and it still doesn't boot. Guess I'll have to get a new CPU

  • You need to have at least one RAM stick in for it to boot otherwise it will never boot. Commented Mar 4, 2016 at 12:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .