I'm having an issue with my wireless router (D-Link DGL-4300).

I've had this router for a couple of years and for the most part it has worked fine.

Recently, however, it seems to be having trouble assigning IP addresses properly to only one machine/device on the network... but not always the same one.

So, here's the scenario: I had 3 wireless devices that were all working: A laptop, a Nintendo Wii, and my Palm Pre. A few weeks ago, the laptop started having trouble connecting to the network... it'd fail to connect almost always, and I'd get a "limited or no connectivity" situation.

Reconnecting, ipconfig /release ipconfig /renew, and repair didn't solve the issue. I assumed the problem was with the laptop since my Wii and my Pre were both connecting with no problems.

After a while I got frustrated and now I have a long cable ethernet cable running to my laptop. However, ever since I stopped trying to connect wirelessly with my laptop, now my Pre won't connect. I get an "IP configuration failed" message.

It seems like whatever is trying to connect most recently won't work, and the other devices will work.

Any idea what may be causing this? Is my router just dying a slow death? What should I do to troubleshoot it?


Looking on dlink.com (click Support Resources then Firmware), I can see that your router model has a firmware update to version 1.9 dating from 9/10/2008.

If you don't have this version, you might consider first updating the firmware before examining further the problem, since this might be a firemware bug that was already fixed in the newer version. This will also reinitialize the router to a known good state.

|improve this answer|||||
  • Interesting, I am using 1.8 firmware from 2007 (which isn't even listed on the site, it goes right from 1.7 to 1.9), but the built-in updater tells me I am using the newest version when I run it. I'll try this when I get home. – TM. Oct 7 '09 at 12:40
  • Be very very careful, and don't do this without having a 1.8 installation or a safeguard that you can use to reestablish the current situation. Firmware on routers can normally be installed from the PC even when they are totally zapped, so this is not as dangerous as flashing the BIOS. But make sure you have all the necessary tools. – harrymc Oct 7 '09 at 19:54
  • Seems to have worked, although I forgot about the issue with the router where it keeps restarting if some wireless tries to connect to it while it boots up. After a few minutes of thinking the 1.9 firmware bricked my router, I finally recalled having the issue in the past, turned my Wii completely off, then was able to start it and restore my settings. – TM. Oct 9 '09 at 4:48

Try assigning fixed IP addresses instead of using DHCP. If the problem is with address clashes caused by a device "remembering" that it has the wrong address, that should fix it.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.