This annoyed me for a while, but as usual; really annoying problems have quite simple solutions.

Some sw I just don't use often enough to remember its hotkeys, like PuTTY. So I end up using the toolbar-menu or the right-click menu to achieve what I need. A couple of times however I have been quite at a loss with PuTTY when right-clicking the title-bar and selecting fullscreen from the menu.

How do I exit fullscreen again without exiting PuTTY? I don't remember the hotkey for it, and now there is no visible menu/title-bar!

--edit-- I still don't know the default "toggle fullscreen" hotkey for PuTTY, so if someone want to enlighten me on that they are very welcome to. :)

  • 3
    Ctrl+right click. -> Full Screen
    – Black
    Oct 4, 2018 at 8:26
  • Thank you @Black. That is also my answer. -And it is even mentioned in the accepted answer :)
    – Superole
    Nov 19, 2018 at 13:57
  • I know, I just added it here for a fast reference :)
    – Black
    Nov 19, 2018 at 14:01

3 Answers 3


From the manual: Full screen mode

If you find the title bar on a maximised window to be ugly or distracting, you can select Full Screen mode to maximise PuTTY ‘even more’. When you select this, PuTTY will expand to fill the whole screen and its borders, title bar and scrollbar will disappear. (You can configure the scrollbar not to disappear in full-screen mode if you want to keep it; see section 4.7.3.)

When you are in full-screen mode, you can still access the system menu if you click the left mouse button in the extreme top left corner of the screen.

It seems you have found yet another way by Ctrl+right click.

You can enable the hotkey using Alt+Enter as shown in the attached screenshot: enter image description here

Once again from the manual:

4.9.7 ‘Full screen on Alt-Enter’

If this option is enabled, then pressing Alt-Enter will cause the PuTTY window to become full-screen. Pressing Alt-Enter again will restore the previous window size.

The full-screen feature is also available from the System menu, even when it is configured not to be available on the Alt-Enter key. See section

  • A very good answer :) Descriptive and also well structured! Me Like ;)
    – Superole
    Jan 7, 2013 at 12:01

Luckily, now I have found the answer. It was trivial as expected, but since it has bothered me on more than one occasion, I decided it deserved a su post. Feel free to disagree with me on that ;)

To access PuTTYs right-click menu when in fullscreen mode just:

  • ctrl + right-click

...from there ofcourse you can choose to exit fullscreen :)

  • Very useful information! Thanks! I almost prefer this over the accepted answer, but both are useful. Oct 25, 2016 at 21:30

If its stuck in windows:


-Press the windows key to open taskbar

-Find the opened putty icon, assuming Windows Aero is enabled (is by default),

-Hold your mouse over the icon, the running instance will hover over that, move to that instance with your mouse,

-Right click that instance and you will see that fullscreen is checked, where you click on that to uncheck.

If aero is not enabled, right click the only icon you see in your taskbar for it, uncheck fullscreen.

Otherwise, there is a setting in putty where you can choose the option to enable an "alt + enter" hotkey.

The latter is nice to leave on. In the event it gets stuck on you, you need to perform the former procedure to restore the window first.

  • Thank you for sharing yet another way of getting out of fullscreen in putty! :) what do you mean by stuck in this answer though? putty process not responding?
    – Superole
    Jan 13, 2016 at 16:08
  • ...and what version of windows have you tried this in? It does not seem to work in win7 as the only options I get from right-clicking the taskbar icon are to close the window, pin putty to the taskbar or launch a new instance.
    – Superole
    Jan 19, 2016 at 15:14
  • It is windows 7 Ult x64, but i think its the same. Check edit please Jan 20, 2016 at 8:11
  • Updated my answer, forgot(oops) to add the detail that it was the popup that was the one i clicked on to get out. :-) But i remember doing it once on the taskbar, it didnt say just Fullscreen with a checkmark, it literally said Exit Fullscreen. It may depend on multi monitor, because i am on a multi monitor setup, witht he putty window in question NOT the same as the one with the taskbar on it. Jan 20, 2016 at 8:19
  • 1
    ok, now I got it to work. It seems to be a very context-dependent solution though (Aero vs Not Aero, Fixed vs Auto Hide taskbar, Single vs Multi monitor, Grouped vs Separate taskbar icons...), and as such it is difficult to explain (and test). But it seems you have found a Windows feature here that I at least was not aware of; Right-clicking any program's running instance representation in the taskbar, is the same as right-clicking the titlebar in that instance's window! And that's quite useful to know! :D
    – Superole
    Jan 27, 2016 at 13:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .