I installed the Java Development Kit (64-bit) recently and saw it includes the JRE plugin for 64-bit as well. But, since Firefox is 32-bit, I also installed JRE 32-bit version. This is what is shown in Programs and Features.

enter image description here

Now, the problem is, the other day, I opened a site which required the Java plugin. The frame showed the regular Java loading animation and hung. Nothing happened after that. Like this:

enter image description here

I checked Firefox's plugins section and it shows Java is enabled, so no issue there

enter image description here

I tried other browsers - IE10 and Chrome but to no avail. It doesn't work anywhere. I saw another question which said that you have to install 64-bit then 32-bit. That's what I actually did as well. First, installed JDK 7 64-bit (which includes JRE 7 64-bit) and then installed JRE 7 32-bit.

I even tried the Java website's Do I have Java? section and over there too, it just keeps spinning for ages (I have waited for more than 10-20 seconds).

enter image description here

How do I go about now? This never happened to me in Windows 7. I am on Windows 8 Pro.

EDIT: I have removed AdBlock, reinstalled the JRE plugin but it still doesn't work.

EDIT 2: I uninstalled JDK (64-bit), JRE (64-bit and 32-bit), restarted my laptop, cleaned the registry and all the cache and temporary files with CCleaner, again installed JDK (64-bit) and then JRE (32-bit; 64-bit is installed along with JDK). Still didn't work. Then I went to this link found on Troubleshooting Java http://www.java.com/en/download/testjava.jsp. The first time it gave an error which I'm unable to recall because when I refreshed, the animation just hung like in the second screenshot above.

EDIT 3: I managed to reproduce the error and I'm attaching the screenshots here

enter image description here

I clicked on details and this is what I saw:

enter image description here

I also tried disabling Kaspersky Internet Security 2013. Didn't work. I have disabled KIS's browser addons: Anti-Banner and Content Blocker. No luck still.

EDIT 4: I tried this on the 64-bit version of Internet Explorer as well. The spinner just keeps rotating like on the 32-bit browsers. Moreover, I tried on my PC at home which runs 32-bit Windows 8. I installed 32-bit JRE on it and well, Java works perfectly on that. So what's the problem with my box?

  • Do you use an Adblocker or NoScript? Dec 21, 2012 at 12:19
  • I have AdBlock Plus. I disabled it completely, restarted Firefox and tried again. Still doesn't work. I read somewhere about something called Java WebStart. What's that?
    – pratnala
    Dec 21, 2012 at 13:16
  • Read here what this Webstart is: en.wikipedia.org/wiki/Java_Web_Start. Try to reinstall the JAVA Runtime. Maybe this fixes it. Dec 21, 2012 at 19:35
  • Please see the edited question
    – pratnala
    Dec 22, 2012 at 14:46
  • Run ProcessMonitor and look if you can see why JAVA doesn't start. Look at the Result column. Dec 22, 2012 at 19:01

2 Answers 2


Download the full 32-bit JRE from here.

Also, try going to the command-line (Ctrl+R, then type in cmd). Once there, type in java and see what happens. If it says something like java not recognized as an internal or external command then it may be a problem with your environment variables.

If it does indeed run and print out its command-line options, then perhaps try looking to see if your browsers for some reason are using an old version of the Java Applet plugins.

In my experience, if the Java Webstart isn't working, its generally because Java isn't set up correctly.

  • 1
    Or you know, you could go back to Windows 7. Dec 23, 2012 at 4:30
  • Which I won't..
    – pratnala
    Dec 23, 2012 at 13:30
  • Did you try what I said above? What did the command prompt say when you typed in java? Dec 23, 2012 at 17:13
  • It gives all the command line options
    – pratnala
    Dec 24, 2012 at 2:55
  • How to fix Java Web Start then?
    – pratnala
    Dec 25, 2012 at 10:21

I had to do a refresh of Windows for some other reason. This time when I installed, everything works now - browser plugin etc.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .