0

It's Christmas time and time for printing labels for all those Christmas cards.

I've upgraded to Windows 7 64-bit from XP. I've been unsuccessfully attempting to get the connected Dymo 400 Turbo label USB printer to work again.

The latest manufacturer drivers have been successfully loaded and installed. The drivers are supposed to work on Windows 7/64-bit. The Win 7 system(s) in question are patched and up-to-date on that score.

The Windows Update site responds with a driver when the USB cable is connected to this printer.

The printer queue seems to be established correctly. What happens is that I submit a job to the printer (either using the DYMO s/w or not), it delays for a period of time, and then I get the message 'printing error'. Can't seem to locate the appropriate error in the new and improved event log.

Several combinations of rebooting, re-installation and power cycling components fail to make the printer work. Sometimes during some type of reset it spits out the last thing to be submitted, but that seems intermittent. I have tried different USB cables and different USB (2.X) ports as well.

I have run the Windows 7 troubleshooter it tries to fix the problem but alas it doesn't.

Interestingly, trying the USB printer (and its associated manufacturer drivers and s/w) on another Windows 7 64-bit system has the identical failures noticed on the original system.

I did not find anything on the manufacturers' site concerning this problem.

The printer has no hardware problems or issues.

4
  • Did you try printing through the Dymo's special Label printing software? I've never had any issues doing it that way. I could just be lucky though.
    – David
    Commented Dec 18, 2012 at 22:02
  • Yep, I used the latest v8.4 software to submit the label request. No joy unless you made the change that I described in my response.
    – mdpc
    Commented Dec 18, 2012 at 22:03
  • I have the exact same model and it worked out of the box. Go figure, anyway I'm glad you have found a solution.
    – David
    Commented Dec 18, 2012 at 22:05
  • My turbo 400 is about 1.5 years old.
    – mdpc
    Commented Dec 18, 2012 at 22:06

1 Answer 1

0

Upon further research, it appears that this is a problem that many Win 7 / 64-bit users have had, apparently with no good resolution. I finally found a solution that works for me and am adding this information as an answer for archival purposes and to help others who have run into this problem.

To allow printing on Win 7/64, you have to do the following:

  1. START-> Devices and Printers (selection is enabled on my systems for all admins)
  2. Right Click on the Turbo 400 Printer Icon for the menu
  3. Select "Printer Properties"
  4. Select "Ports" TAB
  5. UNCHECK the "Enable bidirectional support"
  6. Press "Apply" button.
  7. I'd suggest a reboot to keep things cool all over.

And this allows the label printer to work.

Whew....would have hated to make all those address labels by hand. :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .