I'm experiencing a font issue with Helvetica Neue using Google Chrome Version 23.0.1271.101 on my Mac with OS X Lion 10.7.5

Characters are displayed within boxes.

Prolific on Stack Exchange sites such as Stack Overflow this appears in the user profile areas like Accounts:


Question and Answer sorting:


Expanded usercards:


Loading the same pages in Safari has no issue - the fonts appear normal as expected.

In Chrome, if I load Developer Tools and change the elements font-family the page renders correctly.

CSS specifying Helvetica Neue

body { font-family: 'Helvetica Neue',Helvetica,Arial,Sans-serif; }


CSS without Helvetica Neue

body { font-family: Helvetica,Arial,Sans-serif; }


To assure standard Mac fonts, in Font Book I selected File » Restore Standard Fonts... which did not solve the issue. There are no reported font conflicts in Font Book.

My system has Helvetica Neue installed:


Researching, I found a similar question here of Helvetica font only corrupted in Chrome on OS X; however, no solution.

How can I resolve Helvetica Neue font rendering issues with Google Chrome browser?

  • What version of Chrome? – slhck Nov 26 '12 at 18:36
  • It's version 23.0.1271.91. – Cofey Nov 26 '12 at 19:18
  • Chrome itself doesn't contain Helvetica. It utilizes the one contained in the OS. Reinstalling won't do anything. Your system font itself is corrupted. – Cole Johnson Nov 26 '12 at 19:22
  • Any ideas why it works fine in Firefox and all other apps that use Helvetica? – Cofey Nov 26 '12 at 19:25
  • They probably supply their own distribution of fonts so that OSs without the font requested could be used. – Cole Johnson Nov 26 '12 at 19:30

I've seen that happen before to a workmate. Removing the font and re-installing solved the issue. If you need assistance removing fonts from OSX and reinstalling follow this link


To clear the current user’s font cache, first quit all running applications (otherwise, you may see font oddities after using the command), then open Terminal (in Applications -> Utilities) and run this command:

atsutil databases -removeUser

If you want to remove the font cache for all users, use this command, and provide your admin password when asked:

sudo atsutil databases -remove

Once you’ve cleared the caches, you should stop and restart the ATS server with these commands:

$ atsutil server -shutdown

$ atsutil server -ping

It will take a second or two for the server to restart, but when it does, you should be good to go. If anything still looks odd, a logout and login should take care of any lingering issues.

credit: http://www.macworld.com/article/1139383/fontcacheclear.html

| improve this answer | |
  • Uninstalling the font fallbacks in the font stack which makes text readable; however, reinstalling the font returns the issue as before in Chrome. – Jason Sturges Jan 4 '13 at 18:13
  • @JasonSturges please check my answer edit – Lorenzo Von Matterhorn Jan 4 '13 at 18:42
  • I was unable to uninstall the font (Helvetica Neue), so instead here was my process. So far, it works! 1) Uninstall FontAgent Pro 2) Terminal: atsutil databases -removeUser 3) Reboot & reset params (reboot while holding command+option+r+p) – ioTus Oct 19 '13 at 2:00

I had the same issue and narrowed it down to the HelveticaCY.dfont. After removing this from /Library/Fonts, the issue is gone.

Make sure to clear your font cache and reboot, of course.

UPDATE: and…it keeps happening again and again. A font cache deletion clears it up for about half a day, then bamf, it's back.

| improve this answer | |
  • Did you ever find a permanent fix for this issue? I've been having the same problem the past few months and have to run the commands posted above every few days. So frustrating! – Jeff Dec 16 '14 at 23:00

I had the same issue, but fixed it by deleting DUPLICATE Helvetica or Helvetica Neue fonts.

I am using OS 10.9 Mavericks, and I noticed FontBook had an error which allowed me to automatically resolve one of the fonts, particularly Helvetica. In addition, my third party font manager program, called Linotype FontExplorer X, showed the Helvetica Neue font was installed twice: once as a a system font and the second as a font to be accessed by various non-system applications. When I deselected the duplicate font—so that it was only installed once as a system font—my boxed characters disappeared and the correct font was loaded.

Once these font changes were made with my two font manager programs, I quit Chrome and then opened it again. The problem has been solved for me thus far.

| improve this answer | |
  • 1
    Thanks, that’s it! I had the same problem – some fonts rendered as boxed A characters. The problematic fonts were Helvetica and Courier (monospace). To find out which monospace font is used in Chrome you have to go to [chrome://settings/fonts](chrome://settings/fonts). After deactivating them in FontExplorer X everything worked fine again, no need to use CSS hacks, like described here: Youtube: Google Chrome Helvetica Fix | Helvetica Displaying Improperly in Chrome or the Chrome Plugin Killvetica. – Pwdr Jan 29 '15 at 8:11

It appears that the problem has little to do with all of those things mentioned above (and I've tried them all). Go to FontBook and check your Arial. If you have any other Arial than the system one, remove it and activate the system one (if you've removed system font completely, you can use FontBook restore option). Restart Chrome.

| improve this answer | |
  4. You will see the SANS SERIF selected and in my case it was obviously the corrupted font
  5. Switch to another font like Helvetica Neue
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.