I just installed Windows 8 Pro OEM 64-bit (clean install) and it won't properly recognize my graphics adapter. When I installed Win8, it automatically installed the BasicDisplay.sys driver dated 6/21/2006. 6.2.9200.16384 (win8_rtm.120725-1247).

Hardware - Mobo:MSi G41M-P33 Combo CPU:Intel CoreDuo 6600 Graphics:NVIDIA GeForce 9400GT

OS - Windows 8 Pro 64-bit OEM

The graphics adapter worked fine in Windows XP. The PC is a generic box, bought locally and its mobo failed recently, so I replaced it with the G41M. Microsoft wouldn't let me re-activate Windows XP with a different mobo, so I installed Win8, which appears to work except as described next.

Win8 only partially recognizes the graphics adapter and won't allow NVIDIA latest driver installer to see that it's an NVIDIA card. As a result, OpenGL doesn't work, and this is needed by the software I most use. Other than that the graphics look OK.

When I say 'partially recognizes', I mean that via the Control Panel, I can see that the adapter is described as NVIDIA, but the driver remains stuck at Microsoft Basic Display Adapter no matter what I try, including "Update driver..." in adapter properties.

Display > Screen Resolution > Advanced Settings > Adapter shows:

Adapter Type: **Microsoft Basic Display Adapter**
Chip Type: NVIDIA
DAC Type: NVIDIA Corporation
Bios Information: G27 Board - p381n17 >> Don't know what this means ... 
                                         no mention of 9400GT
Total Available Graphics Memory: 256 MB
Dedicated Video Memory: 0 MB  >> In fact adapter has 512MB on-board video memory.
System Video Memory: 0 MB
Shared System Memory: 256 MB

And Control Panel > Device Manager > Display adapters just shows Microsoft Basic Display Adapter. No other graphics adapter, and no unknown device or yellow question mark.

What I have tried so far:

  1. Cleared CMOS and reset.
  2. Updated BIOS and all mobo drivers as follows:

1st I used Driver Reviver to see if any driver updates were required. It found some but I didn't use that to get the drivers.

Then I switched to MSi's own mobo driver utility Live Update 5. This also showed the board needed to update several so I used it to fetch the new drivers. After that it showed that everything was up to date and I checked with Driver Reviver again, which also reported no drivers now needed updating. Rebooted.

  1. Went to the NVIDIA site to get the latest graphics adapter driver. Their auto-detect "Option 2: Automatically find drivers for my NVIDIA products" said "The NVIDIA Smart Scan was unable to evaluate your system hardware. Please use Option 1 to manually find drivers for your NVIDIA products."

  2. So I downloaded 310.70-desktop-win8-win7-winvista-64bit-international-whql.exe, which lists 9400 GT under supported products, but when I run it, it says: "NVIDIA Installer cannot continue This graphics driver could not find compatible graphics hardware."

  3. Connected the display to the on-board Intel graphics (G41 Intel Express), removed the NVIDIA card and rebooted, changed to internal graphics in CMOS. Again it installs the MS Basic Display Adapter, and can't properly run my s/w that needs OpenGL. It runs on other machines with Intel Express graphics (WinXP and 7)

  4. Shut down and pulled out the power cord. Held start button to discharge all capacitors. Removed and re-inserted NVIDIA adapter in PCI-E slot and made sure properly seated. Connected the monitor to the card, screwed plug to socket. Reconnected power cord. Started and checked in BIOS that Primary Graphics Adapter was set to PCI-E. Started Windows. Uninstalled MS Basic Display Adapter in Device Manager. Screen blanks briefly, reappears. No Graphics adapter entry was then visible in Device Manager. Restarted PC. MS Basic Display Adapter Visible again in Device Manager. Clicked in Device Manager > View > Show hidden devices. No other graphics adapter appears, no unknown devices. Rebooted. Tried Scan for Hardware changes. None detected. Tried right-click on MS Basic Display Adapter > Properties > Driver > Update Driver... Search automatically. It replied that it had determined driver was up to date.

  5. I checked that there were no graphic driver-related entries in Programs and Features that I could delete (none). Searched for any other drivers with nvidia in their name and deleted them, just keeping the 306.97 installer exe file.

  6. Did a Windows Update.

  7. Ran GPU-Z which shows (main items): Microsoft Basic Display Adapter GPU G72 BIOS Device ID 10DE - 01D5 DDR2 Bus Width 32 Bit Memory size 64MB Driver Version nvlddmkm 6.2.9200.16384 (ForceWare 0.00) / Win8 64 NVIDIA SLI Unknown in the drop-down at the foot, "Microsoft Basic Display Adapter" is the only option

If I swap hard disks in that machine to one with a Ubuntu 10.4 installation (originally installed on the same PC), lspci shows "VGA compatible controller as NVIDIA Corporation Device 01d5 (rev a1) (prog-if 00 [VGA controller])" and "kernel driver in use: nvidia"

I'm out of ideas for new things to try and would be really grateful of suggestions.


1 Answer 1


Just to close this, I bought a new graphics adapter - NVIDIA GeForce GT630 810N and Windows 8/MSi mobo can now recognize the adapter correctly, install the driver and run OpenGL.

I changed nothing else, so it's the combination of that specific model of 9400 GT card, the MSi G41M-P33 Combo and Windows 8, that doesn't work, even though the card works in Windows 7.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .