2

When i install pip install PIL then i get this

   *** TKINTER support not available
    *** JPEG support not available
    *** ZLIB (PNG/ZIP) support not available
    *** FREETYPE2 support not available
    *** LITTLECMS support not available
    --------------------------------------------------------------------

I have all the libraries and i tried this as well

sudo ln -s /usr/lib64/libfreetype.so /usr/lib/
sudo ln -s /usr/lib64/libz.so /usr/lib/
sudo ln -s /usr/lib64/libjpeg.so /usr/lib/

how can i install all of the above with pip on centos

2
  • Make sure the libs you need are in the search path.
    – iMom0
    Commented Dec 19, 2012 at 14:50
  • How did you install python? In my experience with package managers, sometimes you need to explicitly install tkinter. I think it's sudo apt-get install python-tk on Ubuntu -- Don't know about centos though. (and this only addresses 1 of your dependency issues ...)
    – mgilson
    Commented Dec 19, 2012 at 14:51

1 Answer 1

7

You need the required headers from the corresponding libraries: libjpeg, libpng, and others.

Usually, you will need the dev packages for those libraries to have the headers.


Nevertheless, installing PIL is usually pretty complicated as it often fails to detect the libraries. You should do pip install pillow instead. pillow is an installer for PIL, which finds libraries more easily.

4
  • 1
    I have those so installed but how can PIL find them
    – user1914461
    Commented Dec 19, 2012 at 15:04
  • @user1914461 Did you try installing pillow as I suggested? Commented Dec 19, 2012 at 15:08
  • Thanks buddy , i first removed PIL and pillow and then again installed pillow only and everthing is ok now , thanks
    – user1914461
    Commented Dec 19, 2012 at 15:12
  • @user1914461 : ) Commented Dec 19, 2012 at 15:15

You must log in to answer this question.