9

Installing a VMware Workstation 7.1 Windows 7 VM, and find that I cannot enable hibernation with powercfg -h on. Windows says

An internal system component has disabled hibernation

What's wrong and how to fix it?

enter image description here

3

Use the registry to enable hibernation back.

  1. start regedit.exe
  2. go to the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentCongtrolSet\Control\Power
  3. change the value HibernateEnabled from 0 to 1.

Now reboot and look if you have hibernation back.

| improve this answer | |
  • Checked that key, no luck, HibernateEnabled is already set to 1. – Jimm Chen Dec 20 '12 at 7:32
  • ok, in this case set it 0 and reboot and now try to run the powercfg command. – magicandre1981 Dec 20 '12 at 12:05
  • Changing from 1 to 0 caused only that it disappeared from System menu, I still cannot enable it. – Betlista Feb 22 '17 at 6:42
2

I finally got it. Windows 7 and 8 does not allow hibernation if it is installed inside a VHD.

Windows 7 powercfg.exe does not make it explicit. Windows 8 does, a screen shot below:

enter image description here

I cannot figure out the reason why Microsoft impose such limitation. If he puts hiberfil.sys onto a partition from a real disk , things should be able to go smooth.

BUT, is there a way to know it on Windows 7, through a system log or something?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.