107

Sometimes, when I start my machine, the volume control is set to 100, but it plays relatively quiet. I can fix it by rebooting my machine. Is there a way to restart audio devices, without rebooting the computer?

  • 2
    have you tried to go into the device manager, find audio file, click right mouse button on it and choose disable. After that once again and choose enable. Hope it works ;) – mnmnc Dec 20 '12 at 11:15
  • Nice idea, device manager lists two "High Definition Audio Device"s under "Sound, video and game controllers". I am able to disable one of them but when I try to disable the second I get a prompt asking to reboot my machine. – xylar Dec 20 '12 at 11:35
  • Try updating your audio drivers too. – Bigbio2002 Jan 3 '13 at 20:18
142

I also had to stop AudioEndpointBuilder and restart it

net stop audiosrv
net stop AudioEndpointBuilder
net start audiosrv
net start AudioEndpointBuilder

If you look at Windows' Task Manager's "services" tab, that might help you identify what services you have tied to audio.

| improve this answer | |
  • 25
    On my system, net start audiosrv also started AudioEndpointBuilder so no need for the final line. – xylar Feb 18 '13 at 11:11
  • This doesn't work for my case using Windows 7 32-bit on a HP Mini netbook. Sleeping and waking the computer usually fixes it but in some situations (such as partially buffered YouTube videos) this can have other annoying side effects besides fixing the sound. – hippietrail Feb 16 '14 at 10:35
  • 9
    Similar to @xylar comment: Windows Audio service is dependent on Windows Audio Endpoint Builder. Typically when you want to manually start/stop services that involve dependencies they should be nested in the form: stop A, stop B, start B, start A, where A depends on B. Another option is to use services.msc and Restart the lowest level service, which in this case is Windows Audio Endpoint Builder. That automatically executes all the above in proper order. – merv Jun 21 '14 at 18:21
  • 2
    SO glad I decided to Google this! -- put the above in a batch script, and BAM, my audio is working again! -- No more need to restart every time my audio craps out on me. -- Freaking awesome. :D – BrainSlugs83 Sep 30 '14 at 17:22
  • 5
    In Windows 10 it may help if you start cmd in Administrator mode. – user1205901 - Reinstate Monica Mar 20 '16 at 12:58
38

Open up a command prompt as administrator and run:

net stop audiosrv
net start audiosrv

This restarts the Windows service responsible for handling audio.

| improve this answer | |
  • Thanks god, stupid drivers crashing audio jack on log out. – Warpzit Oct 3 '14 at 9:03
  • 2
    Not for Windows 10 :( – kokbira Oct 14 '15 at 1:35
12

For Windows 7, I used this and hope it will work for all Windows flavors:

  1. Right click on My Computer
  2. Chose Manage
  3. Select Device Manager in the left panel
  4. Expand Sound, video and game controllers
  5. Find your audio driver and right click on it.
  6. Chose Disable
  7. Right click on the audio driver again
  8. Chose Enable

It should start working now.

| improve this answer | |
  • 2
    Not for Windows 10 :( – kokbira Oct 14 '15 at 1:35
  • 2
    Not for Windows 7 either, at least not if you care about the "without restarting" part of the question. – aroth Mar 6 '16 at 12:32
  • 1
    @kokbira You can access it using Windows Settings -> Hardware – tmighty Sep 7 '18 at 20:18
  • This worked on Windows 10. I clicked on View menu / View Devices by Connection and then disabled/reenabled the root item Intel...Audio Controller instead of the child Speakers (Realtek(R) Audio). BOOM I got windows audio working again without restart. – Gerardo Grignoli Mar 8 at 14:35
1

Thanks for the answer, it helped me too. Something stuck in my sound card buffer and kept looping. I was not able to disable my card in Device Manager, (it wanted to restart Windows 7). But stopping the service helped, (though only that did not solve my problem alone).

So this is what I did:

net stop audiosrv
net stop AudioEndpointBuilder

Then I was bale to disable the audio device in Device Manager. Then I re-enabled it, and

net start audiosrv

This reset my card and solved my issue.

| improve this answer | |
  • Not for Windows 10 :( – kokbira Oct 14 '15 at 1:36
0

This problem is intensely annoying. I have found a solution that works for me. It isn't permanent as you have to do it each time the speakers stop, but it is better than restarting all the time.

Go to Device Manager Right click on Sound video and game controllers and click "scan for hardware changes"

That works for me.

| improve this answer | |
0

Check your device manager and go to audio in and outputs. Now check the box show hidden devices (in view) and delete all the devices other than the ones that you have when you didn't show the hidden devices. Reboot.

There must have been some leftover drivers that interfered.

| improve this answer | |
0

I came looking for a way to restart my Creative X-Fi Titanium driver w/out restarting. Sometimes when I change the Mode, I'll get a buzz out of the right channel that may force me to restart Win7 several times to get rid of.

This fix didn't work for me but as I was unable to Disable the X-Fi in the Device Mgr., which stated it would require a restart when I tried. I'd tried to kill all related software, but maybe there was something I missed, being the massive driver that it is.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.