My question is about giving Internet connection to a VM with a STATIC IP address, by connecting to the WiFi I have at home. I gave my VM, running Ubuntu Server 12.04 on VMWare Player, one network adapter using the bridged mode, so that the VM is directly added to the physical network (WiFi). I did no network setup on my Windows 7 host.

So what I first did, after setting the network on VMWare Player, was to edit the /etc/network/interfaces file of my guest OS (Ubuntu Server) and put the following

auto eth0
iface eth0 inet dhcp

I restarted the network service with

/etc/init.d/networking restart

My VM got the IP and I could ping google.com and the gateway, but not my Windows 7 host machine connected to the Wifi ... Why is that ? What did I not do ?

Then I changed the /etc/network/interfaces file, and gave my VM a static IP, equal to the one it had gotten from the DHCP server before (

auto eth0
iface eth0 inet static
    gateway #same as showed in the result of ipconfig on my W7 host

I restarted the network, and I could only ping the gateway. I could not ping google.com or the W7 host (

What am I missing to just connect my VM to the Wifi ?? Thanks a lot for your help. Don't hesitate to redirect me to useful resources.

  • Worked more on my problem, and it's almost solved. The steps are 1- disable all vm adapters on host 2- take the wifi card properties, and enable "vmware bridged protocol" The wifi card should be the only NIC to have "vmware bridged protocol" enabled 3- go to vmware (player or workstation) and set up one network adapter, in bridged mode 4- go into your vm, and assign your vm a static IP address on the wifi network and restart the networking service. You should be able to ping google.com --- PROBLEM : I can't ping my host machine, while I should. I need help on why that doesn't work – Myna Dec 21 '12 at 9:11
  • Disable the firewall for pinging the host. – Myna Dec 22 '12 at 10:35
  • Well, if you arrive at an answer, please post it as such. Then, after some timed has passed, you can accept your own answer. – Daniel B Aug 22 '14 at 19:03

I had the same problem. I solved disabling Citrix DNE Lightweight Filter from my network adapter properties. If you are using a Realteck adapter, you can take a look at KB1025978 and KB1015940

You can check this question

VMware Workstation Bridged Network Host UnReachable


Same problem with W7 host and Linux guests with bridged network. No Host/Guest connectivity, other remote connections work fine. Disabling Link Layer Topology Discovery drivers in the Networking properties of my Local Area Connection solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.