I would like to configure a second wireless router on my existing network. The router that I have received from my ISP has problems with wireless and its DHCP server is playing, therefore I would like to configure a second router as the access point and primary DHCP server.

The first router is a Dlink (DSL-2780 - ADSL Router) and the second router I have is a Belkin (N300 Surf - Cable Connection).

I have searched online and tried to configure it but I am unable get access to the internet from the Belkin router and I think the default gateway setting are incorrect as it needs to be the IP address of the first router. How do I go about changing this setting?

Here is what I have configured so far:

  1. DSL-2780 router
    • IP address:
    • Wireless turned off
    • DHCP turned on and the range is - 100
  2. Belkin N300 Surf router
    • Connected to the first router via ethernet cable on LAN port 4
    • IP address:
    • DHCP turned on and the range is -

Then I connected a laptop with an ethernet cable to the Belkin router, typed ipconfig and found the following IP address details:

  • IP address:
  • Subnet mask:
  • Default gateway:

On this laptop I'm unable to get internet access. Can someone advise what changes I need to make to ensure this is working fine?

If I connect directly to the DLink router then I can get internet access without any issues. ipconfig gives the following details:

  • IP address:
  • Subnet mask:
  • Default gateway:
  • Have you tried in Static IP mode? Set the default gateway of the second router as and see what happens. In the second router, IP address: Subnet mask: Default gateway: – user337428 Jun 21 '14 at 16:25

Both routers are saying that they are the router connected to the internet by issuing their own address as the default gateway. However, only the DSL router is a gateway - it is the only device with a connection to the internet.

So if the Belkin is going to be a DHCP server, it is going to have to issue the IP address of the DSL router as the default gateway in DHCP. I have never seen a domestic router that will let you do this.

The only option you really have is to switch off DHCP on the Belkin. Don't worry, because you have connected the two routers by their lan ports, they are on the same broadcast domain. This means that devices that connect to the Belkin by wifi or lan will issue DHCP requests, and they will be seen and responded to by the DLink.

  • Can I use routing table or advance routing to achieve ? – user1754675 Dec 21 '12 at 12:29
  • The belkin is not doing any routing, so no. It is acting as a layer 2 device only - or at least in this case, it should only be later 2 (local network) whereas you have made the network think it is later 3 (router) which it isn't. – Paul Dec 21 '12 at 12:52

You just have to turn off DHCP and NAT on the second router (Belkin), since you are using it as an access point.

  • NAT being on or off has no bearing on a router used as an access point. DHCP is the only consideration. – Paul Dec 21 '12 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.