After an accidental submersion in some water, my Thinkpad X201 is still functioning just fine, except that the center (blue) trackpoint button appears to 'click' roughly once a second. This is actually a pretty serious annoyance in many situations.

I've never used the button, so I'm perfectly fine just disabling it altogether. Unfortunately the TrackPoint driver pane (along with other Mouse settings in the control panel) only allows me to toggle between scroll, zoom, and click functionality, all of which are undesirable when activated constantly.

Note that this X201 configuration has only the trackpoint, without the trackpad and additional set of buttons (UltraNav) found in other configurations or newer Thinkpads.

Is there any way to disable the middle button entirely?

  • What model of ThinkPad? – CharlieRB Dec 21 '12 at 13:01
  • I've updated the question with additional information. – DNS Dec 21 '12 at 13:56

The TrackPoint driver application has this ability. Have you installed the UtraNav driver package? This link is for Windows 7 but they are readily downloadable. UltraNav

  • Sorry, I should have been clearer in the question, but my X201 doesn't have UltraNav; only the trackpoint. The Ultranav package won't start unless it detects the dual trackpoint/trackpad. – DNS Dec 21 '12 at 14:12

I finally solved this using a tool called AutoHotKey. I used Device Manager to replace the TrackPoint driver with Microsoft's generic PS/2 mouse driver, then wrote the following AHK script:


This remaps the middle button (and any modifier-key combinations) to a no-op.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.