3

First - I have gone through as many possible solutions I've found here and elsewhere.

[Edit - to describe the issue in more detail, the PC appears to boot correctly, but instead of the logon screen, I have been getting a black screen WITH the pointer cursor, and it responds correctly to the mouse. Pressing CTL-ALT-DEL brings up the logon screen's background, but with no logon area nor any other content. This screen was at the full resolution before I uninstalled the graphics driver in safe-mode.]

I also just ran a full up-to-date AVG scan from boot media.

[Edit - the AVG scan, which was updated to today's virus signatures, found no issues at all.]

So - steps I've tried:

  1. Safe Boot, Restore from before the issue - done, no help.
  2. Uninstall the graphics driver - done, now i have a 1024x768 fallback screen, still no way in.
  3. sfc /scannow - only doable from Safe boot obviously, but no change.
  4. [Edit - booting from restore media, performing a startup repair and...]Restore further back - restored to 2 days ago, and I'd had many reboots since then with no problem.
  5. Enable autologin to try to get beyond the login screen - done, doesn't work.

It seems the best advice is complete reinstall, but I really don't want to do that because it'll take 3-4 days to add all the apps I use.

Some key points to note - in both states - before and after removing the video driver, I always had a mouse cursor on the screen. CTL-ALT-DEL flashes up the login background, but no login info.

I can (and often do) reinstall from scratch, but was at a fairly stable state before this, and would prefer not to.

-Paul

  • I assume you have removed the video driver completly. – Ramhound Dec 21 '12 at 16:07
  • @ramhound yes, and when i do boot fully back I'm now in fallback 1024x768, with exactly the same behaviour - ie black screen, with cursor, ctl-alt-del temporarily brings up the login screen background. – PJC Dec 21 '12 at 16:19
  • Have you tried to boot with a Widows 7 disc to do a repair? – CharlieRB Dec 21 '12 at 17:48
  • @CharlieRB - yes - I should amend the question - the second rollback was from boot media, and after a startup repair. – PJC Dec 21 '12 at 17:56
  • 1
    Have you tried to chkdsk the system drive? – gronostaj May 6 '13 at 13:18
1

This sounds like your Credential Providers got messed up. If you're able to boot your system into safe mode, please open the registry editor and navigate to this registry path

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers  

You'll see subpaths in GUID format which are all Credential Providers that are available on your system.

Please check each path if it contains a REG_DWORD value named Disabled and if so, delete this value. On my system there is only one credential provider that is deactivated which is the PINLogonProvider value with the data:

{cb82ea12-9f71-446d-89e1-8d0924e1256e}
| improve this answer | |
0

This really sounds like something has corrupted user permissions/account. I have never actually seen this on a system that was working before but this link looks promising: http://www.sevenforums.com/crashes-debugging/27414-blank-screen-cursor-but-no-log-screen.html

| improve this answer | |
  • Already tried everything on that thread with no joy, plus note this PC has been running happily for over a year. – PJC Dec 21 '12 at 18:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.