67

When I scroll along the page or some scrollbox with two fingers on MacBook Pro touchpad, and it can be no longer scrolled to the left, Firefox decides I want to go back in history.

What can I do to disable history navigation using two-finger swipe in Firefox 17? I'm happy with using Backspace for going backwards, and wiping out all the text I was writing somewhere in some forms when I accidentally scroll more than I'm allowed is really frustrating.

2 Answers 2

106

I like the following solution better (than the existing answer) because it only affects Firefox:

  1. In Firefox, go to "about:config"
  2. Change the value for "browser.gesture.swipe.left" to "cmd_scrollLeft" (instead of "Browser:BackOrBackDuplicate")
  3. Change the value for "browser.gesture.swipe.right" to "cmd_scrollRight" (instead of "Browser:ForwardOrForwardDuplicate")

enter image description here

5
  • 7
    This is awesome! Finally there is solution that WORKS. Thank you so much! And welcome to SuperUser — good start :)
    – toriningen
    Commented Sep 10, 2013 at 0:53
  • I know it is against policy to leave "thank you" comments, but that issue was haunting me for years already. Thanks!
    – Anton
    Commented Dec 3, 2019 at 8:23
  • Still works with Firefox Quantum (tested with 68.3esr) under OSX Mojave (tested with 10.14.6). Yay!
    – Bryan P
    Commented Dec 12, 2019 at 18:29
  • Does this solution still work for mac users? I want to turn swipe=back off on linux (FF 100), but can't make it happen..
    – BlackShift
    Commented Aug 8, 2022 at 18:03
  • thank you! :) what a stupid default setting!!!
    – Tilo
    Commented Mar 24, 2023 at 21:20
18

UPDATE:

There is a native way to do this. Go to System Preferences / Trackpad / More Gestures and deactivate the checkbox for "Swipe between pages" (first checkbox). This works at least for Mountain Lion.


The old, non-functional answer was:

I do not know of a native option in OSX (ML, 10.8.x), but there is a nice trick to do it:

Download the free BetterTouchTool. It lets you map a huge amount of functions to trackpad & mouse gestures as well as keyboard shortcuts. You can set "No action" and you can decide, which applications should know your new custom gesture/shortcut.

So I just mapped the two finger swipe (left & right) to "No action" only for Firefox, Chrome, Safari, Opera and Sleipnir.

Hugely useful and it will solve your problem.

4
  • Good first post. Sounds like a potential solution.
    – nixda
    Commented Dec 30, 2012 at 3:32
  • Unfortunately, tried on OSX Lion (10.7.x) and latest currently available BTT — it surely handles two-finger swipes in either direction, but default action (e.g. history navigation) is also triggered with wherever action I set for swipe in BTT. So if I set "show Mission Control" action for swipe, I get both history navigation AND mission control invokation. :( Is there something additional to look for?
    – toriningen
    Commented Dec 30, 2012 at 9:22
  • Oops. How embarrassing! Good: I tested it myself before posting. Bad: I tried it on a browser tab without a history (so obviously there is nowhere to swipe to). But: I got it working. In System preferences / Trackpad / More Gestures. I can set "Swipe between pages" off. This works for me (Mountain Lion) I am updating the answer to reflect this.
    – Oliver
    Commented Dec 30, 2012 at 11:23
  • 3
    Disabling system-wide swipe gesture disables it not only in Firefox, but also in Preview and Finder, and other apps where it's considered useful, and makes them inconvenient to use.
    – toriningen
    Commented Feb 16, 2013 at 17:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .