Google Chrome is quick, works for lots of websites. But I found out that it would not save my password when I log into Gmail!

8 Answers 8


If you are signed into Chrome with same account, Chrome won’t ask to save the password. Following these steps you can force Chrome to ask "save password" again:

  1. In chrome > Settings > Disconnect your Google Account.
  2. Log off all gmail sessions that you could have open.
  3. Go to gmail login page.
  4. Type login and password (with @gmail.com recommended) and google will ask you for save it again!
  5. In chrome > Settings > Sign in to Chrome.
  6. Allow Chrome to sync the data (bookmarks, passwords...)

And that's it! Enjoy!

I've found the solution in this video: https://www.youtube.com/watch?v=Bvb1lK1Felo

  • It isn't fully clear how this answer addresses the author's question.
    – Ramhound
    Jun 15, 2015 at 11:55
  • @Ramhound If you are signed into Chrome with same account, Chrome won’t ask to save the password. It’s said in the video linked (the source of this steps).
    – Mark
    Jun 15, 2015 at 12:31
  • 2
    As of April 2020, this solution still works.
    – TML
    Apr 13, 2020 at 19:53

Because Gmail uses javascript to redirect the page very quickly, we may not have the chance to click "Save Password" on Gmail. Instead, try visiting accounts.google.com. Login there and you'd be able to save your password. Of course, saving it there would mean you can use it when logging into Gmail.

  • 5
    This solution does not work anymore.
    – crypdick
    Dec 4, 2016 at 0:19

I've just solved the problem by doing:

Passwords > Google account > Password Options

Then, export your passwords to a CSV format. Open the file, remove everything other than the header and add your credentials to it. Then, import the CSV file and your Gmail password will be there.

  • This doesn't address the poster's problem. Export only exports passwords that are already saved. The question was how to save the password in the first place.
    – Robert M.
    Jan 27, 2022 at 22:21
  • @RobertM.: "remove everything other than the header and add your credentials to it. Then, import the CSV file" worked for me
    – Greg
    Feb 28, 2022 at 16:49
  • @Greg My bad, I get it now. It works.
    – Robert M.
    Mar 1, 2022 at 19:11

Here is the latest solution on Google Official https://support.google.com/accounts/answer/10500247?hl=en. Just add those passwords in CSV which are to be imported. Moreover for format, you can Export Current passwords and delete everything except header, now add desired password. After this upload CSV as specified in the link above.

  • 1
    This should be the top reply. It's the only solution that works as of January 2022.
    – Robert M.
    Jan 27, 2022 at 22:30

For the past few years Chrome has not offered to save Google passwords no matter what I've done. I believe this is because they are pushing users to use profiles and turn on "Allow Chrome sign-in".

Please note, this problem is specific only to Google sites and my passwords are saving fine on every other domain.

My solution was to simply open the password manager and click "Add" to add them manually, using "accounts.google.com" as the domain. This may be a cumbersome solution for some but for me there there are only a couple so it was easy enough.

  • Phew, this worked for me after various other methods failed. Thanks!
    – Dominick
    Aug 1, 2023 at 16:46

Check in your browser that when it wants to save your password you choose correct answer:"Save this Password"

in Setting search password and find this option:

Offer to save passwords I enter on the web
  • 1
    The browser offers to save, but doesn't save the password until one actually clicks on the little pop-up button. As the other person said, Gmail is very fast, so the particular problem occurs. Dec 24, 2012 at 6:17
  • 1
    even with this option checked off, you'll still not be able to save password in Gmail
    – user22105
    Dec 24, 2012 at 15:42

Nowadays the only solution is to add it manually. In chrome enter settings -> Autofill -> Password manager Under Saved passwords, click "Add".

In website enter accounts.google.com.

In user name enter your full google account email adress.

In password enter your password.


I have solved this problem. It's very simple, you cannot use your Google Password for GMail because you are logged out of all Google services, including your Google Password Manager.

To solve this, save the Google password on your local machine.

Google Password Manager > Add Password > "Save only on this device" (instead of "Save in your Google Account"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .