14

When I remote into my Windows 8 desktop with Windows 7 it works fine but when try with Windows 8 I get an empty screen after it connects. Keyboard commands work despite the screen being black; I can open Explorer etc. using them and they persist when I reconnect with Windows 7.

Any ideas on what is wrong?

3
  • Have you fully patched both computers including option updates? (RDP version 8.0 has come out several weeks ago on Windows 7 and maybe also on 8).
    – harrymc
    Jan 10, 2013 at 15:06
  • In addition to @harrymc's suggestion, take a look at the source Win8 RDP settings. Also, are the source (Win7 and Win8) hosts on the same LAN as the target Win8, and the NIC and Comms port speeds verified OK? Lastly, try different NIC ports for the source hosts on your switch.
    – Lizz
    Jan 11, 2013 at 6:35
  • Does changing the Windows 8 theme have any effect? On the Experience tab for Remote Desktop Connection, what happens if you connect choosing Modem (28.8 Kbps) and deselect Bitmap Caching?
    – user314104
    Jul 30, 2013 at 1:13

4 Answers 4

6

This Technet thread suggests:

  1. Type Ctrl + Alt + End
  2. Then cancel
  3. Then exiting and reconnecting

You could also try disabling bitmap caching using this KB article.

1
  • Ctrl+Alt+End worked for me, it brought up the Options where I could start the Task Manager and then could tab to other windows. I found out that I had left Firefox in fullscreen mode, and it was not refreshing, causing the black screen. Aug 20, 2015 at 15:33
4

Open the Local Group Policy Editor on the machine you are running the Remote Desktop client.

Under Computer Configuration>Administrative Templates>Windows Components>Remote Desktop Services?Remote Desktop Connection Client

Enable the setting called Turn Off UDP On Client

Now I'm able to connect without issue... somehow UDP isn't making it through and this change fixes the problem!

Should anyone wish to change the setting from registry rather than through group policy, here's the place to do that:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client

Create\set fClientDisableUDP (REG_DWORD) to 1.

PS> Set-ItemProperty -Path 'HKLM:\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client' -Name fClientDisableUDP -Value 1
1

This was caused for me by a mis-configured port forwarding setting on the remote router on the server side. I was only forwarding TCP traffic, not UDP. Once I modified the port forwarding settings to forward both TCP and UDP, the problem was resolved.

The problem for me was intermittent until resolved. It looks like Remote Desktop sometimes uses only TCP and may fall back to UDP occasionally. If it does fall back to UDP and UDP is not being passed through, then you get the black screen on the remote client and/or disconnect messages such as "Failed to reconnect to your remote session. Please try to connect again."

0

I spent hours diagnosing this issue, "Turn Off UDP On Client" works around it for me also.

Turns out our office Draytek 2820 has a UDP flood DoS attack trigger which was set to 300 packets / second. Upping to 1000 packets per second resolves this for me.

1
  • Yes it does. "Any idea what is wrong?" Yes. My router UDP flood attack was false triggering. Exactly the same symptoms and that fixed it. This answers the question. Jul 13, 2014 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.