So I installed Linux Mint 14 on my computer today, set up a dualboot with Windows 7. Now the generic wireless driver for my Netgear wg111v2 dongle did not work properly (very bad reception, constant disconnection - seems like the hardware settings were all wrong) so I installed ndiswrapper using the correct netgear driver, which works fine under Windows 7, by the way.

I noticed the ndiswrapper-dkms version I got off apt-get failed to build on my kernel, so I got the sources, built them manually and all went well - sudo modprobe ndiswrapper succeeded with no errors.

I rebooted to apply those changes.

After reboot, my wireless device is gone. This is what I get for the ndiswrapper driver list:

ray@ray ~ $ ndiswrapper -l
net111v2 : driver installed
    device (0846:6A00) present (alternate driver: rtl8187)

This is the version information:

ray@ray ~ $ ndiswrapper -v
utils version: '1.9', utils version needed by module: '1.9'
module details:
filename:       /lib/modules/3.5.0-17-generic/misc/ndiswrapper.ko
version:        1.58rc1
vermagic:       3.5.0-17-generic SMP mod_unload modversions

Yet no wireless device is available:

ray@ray ~ $ iwconfig wlan0
wlan0     No such device

The ndiswrapper GUI is also gone, even though the ndiswrapper module is up and running. I should mention I removed the ndiswrapper-common package out of frustration hoping to reinstall it properly, that's probably the reason everything is gone, yet I can't find a way to enable the driver from command-line.

What should I do restore my wireless network?

1 Answer 1


For the poor souls who will undoubtedly have this problem in the future, read on...

Relevant device: NETGEAR wg111v2 USB 2.0 WiFi dongle though I suppose the problem is rather widespread, since the driver is generic to most network USB devices. Give it a try, I guess.

Symptoms: ridiculously high packet loss, random disconnections (sometimes instantly), essentially rendering the network unusable. You may as well be sending carrier pigeons to the server.

Potential Solution:

*1. Ditch ndiswrapper - it does not work with this device, or at least not on my kernel.

*2.The generic, open-source driver (the one which was enabled during the installation of your distro) does in fact work, but its default settings are rather insane. First, make sure it's actually loaded:

sudo modprobe rtl8187

Where rtl8187 is the name of the driver for this device. Hopefully this works.

*3. Now, initialise the default wlan0 interface (if it already exists, you can skip this):

sudo ifconfig wlan0 up

*4. If you want some detailed information (for troubleshooting or whatever), you can use:

sudo iwlist wlan0 scan

*5. At this point you haven't done anything yet, but now we're going to be changing some settings of the dongle so that it can actually operate properly. We'll change the transfer rate to something better:

sudo iwconfig wlan0 rate 5.5M auto

*6. The connection should now be infinitely more stable. It might not be perfect, depending on a lot of variables (how far you are from your router, etc...), so you can force it to stay at this rate:

sudo  iwconfig wlan0 rate 5.5M fixed

Note this will limit your network speed to ~700kB/s, however the device will no longer try and change its transfer rate spontaneously, which will make the connection more stable (hopefully).

*7. If that's not good enough, try tweaking the transfer rate up and down until you no longer experience the original symptoms (or at least, to the point where you can live with them).

If this doesn't help you, well, I don't know what to tell you. It worked for me :(

Original reference: https://wiki.archlinux.org/index.php/Rtl8187_wireless (gave brief summary of contents in case link target is no longer available at a future date, as per site FAQ)

  • I should note I still get disconnected from time to time, but it's gotten very rare (every other day or so) and is always fixed by plugging out the dongle and plugging it back in, and re-entering the above commands (make it a script in init.rc). Also, if the network won't go back up, go in the Network Manager, open your wireless settings and hit "Save" without changing anything. For some reason it works after doing that.
    – Thomas
    May 11, 2013 at 13:07
  • Sorry, that was rc.local, shouldn't write comments so late.
    – Thomas
    May 12, 2013 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.