I recently had a friend install gitolite on my Ubuntu server, however when he did so, he setup the git user in the default /home/git, instead of where I would like... /var/git/. Several minutes ago I attempted to move everything over to the directory where I would like the repositories to live, however I broke everything...

All I know is that I am running gitolite v3.2 assuming installed from the Ubunto Repo. apt-get install gitolite yields gitolite is already the newest version.

What I did:

cp -r /home/git /var/
mv /home/git /home/git_bak
usermod -d /var/git/ git

After doing this I attempted to use my development machine to login to the git repository: ssh git@example.com, which should usually yield the results of the gitolite configuration listing all the repositories and then closing the connection... however instead.. it allows me to login to bash... meaning whatever the default shell is is incorrect? Or whatever daemon the GIT server is supposed to be running is not... Even after reboot nothing comes back, and I am unaware of any gitolite directories other than in the home folder, so i have been unable to locate any log files or configuration files.

At this point I knew something went wrong, so I reverted everything that I had done

mv /home/git_bak /home/git
usermod -d /home/git/ git

And I again attempted to login via ssh, again, able to login to bash, gitolite not running... Also attempted to clone a repository, and I receive a password login prompt as opposed to the usual pub key pass phrase prompt, as well as a git repository not found error...

I broke it an I need help :( Any and all help is greatly appreciated.

I will also take instructions on how to do a complete reinstall. I have tried multiple setup guides, and every time i get hung up with the RSA keys, as it will not allow me to log into the server using my key. I continually get 'Enter passphrase for key .ssh/....', even on correct entry, i get the same prompt, or i will get: 'password for git2example.com'.

  • (1) What is the gitolite version? (2) How was it install? (Ubuntu repo / gitolite repo) – John Siu Dec 27 '12 at 16:04
  • (1) 3.1 (2) I am unsure. apt-get install gitolite yields gitolite is already the newest version so I am assuming the Ubuntu Repo. – Matt Clark Dec 27 '12 at 17:16

I ended up backing up all of my files, deleting everything git, and starting from the beginning with a backed up repository directory. For those interested, I followed this: tutorial.


You could make a symlink to the new directory (ln -s).

  • I had a complete backup of the old gitolite repository directory, with all permissions preserved, however copying that right back over the new repository directory solved nothing... Gitolite still told me that I had 0 projects... So symlinking it would not work, as it would essentially appear t the system the same as copying it all into the folder. – Matt Clark Jan 2 '13 at 16:18
  • okay, if you have set of files, your program works fine with it and then you copy it to the another place . You do symlink and ... your prohram doesn't work. Okay. Where is the magic? – Antony Tren'kin Jan 2 '13 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.