8

This is strange but lately, I have seen that Google Chrome is showing fonts which are Italics and Bold. I was unaware until I used Firefox. What might be the problem?

Firefox

Fonts in Firefox

Google Chrome

Fonts in Chrome

Chrome Settings

Chrome Settings

7

11 Answers 11

2

Just so that other people too can have an answer - Try installing "European Union Expansion Font Update" from Microsoft. This solution is what I found at Google Forums and it helped me and I didn't needed to format my PC Hope it helps others too.

1
2

PROBLEM

On Windows, Helvetica family fonts do not exist by default. If you install Helvetica or Helvetica Neue, fonts of many web pages, even extensions will change in Google Chrome. They might become Bold, Italic or both.

SOLUTION

  1. Close Google Chrome

  2. Go to Control Panel → Appearance and Personalization → Fonts, Or go to. C:\Windows\Fonts.

  3. Delete all Helvetica and Helvetica Neue fonts family

  4. Re-open Google Chrome

    In this step the problem should be already fixed! If not, it is because the fonts still exist in the Windows Registry. So proceed to these additional steps:

  5. Close Google Chrome again.

  6. Run Registry Editor. Press Windows key + R to open Run dialog, Type regedit, then hit Enter.

  7. Navigate the following folder HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts.

  8. Select all Helvetica and Helvetica Neue fonts, Right-click on the highlighted fonts, then select Delete.

  9. Re-open Google Chrome.

1

I saw that I was getting BOLD font in Google Chrome and it was due to "Open Sans" font which I installed.

Was only happening in chrome and not in Firefox or Internet Explorer

I deleted the font and reinstalled it (from the original zip file)

This has fixed the problem in Google Chrome

Thanks

1

I found the answer to my annoying Italic and Bold font rendering with Chrome browser situation. I'm using winXP and I went through my font folders and tried many things. Apparently there are two versions of Arial font. One that is 359 kb version 2.95 Modified August 4, 2004, 3:00pm and another Arial that is 290 kb version 2.95 Modified April 10, 2007, 12:00pm. There is an advice I followed and that is to open the Custom.css file and write the following Code.

@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial');

Open the Custom.css file with note pad and then save it as all files not with .txt extension and you solve the annoying issue and can continue using chrome care free.

You need to find this particular kind of Arial font so that this custom fix will work. No more deleting fonts that are valuable to some like others have suggested.

1

Or you delete just this font: Helvetica Neue Noir Italique. This worked for me.

1

So partial thanks to some answers, but instead of closing chrome, I copied all my helvetica fonts (i'm a designer, i had 50+) into another folder. Since it detects which is in use... I decided I'd rather delete that one instead to at least get rid of the boldness which was fine by me.

So, closed chrome and as I guessed i was able to delete the Helvetica Bold font (it's a system font, but it'll overwrite as another font if needed)

So, opened Chrome and all was fixed (although it did go to the next font after helvetica... But better than that bold font!)

1

I tried out all kinds of tips. But nothing worked. In my case all I had to do was to go to the fonts folder C:\windows\fonts and delete the only Helvetica font that was in there. It was called Helvetica bold and for whatever reason Chrome seemed to feel the need to use that font for displaying regular websites like facebook.

Once I had that font deleted, chrome rendered all websites like Firefox in a non-bold font.

I have no clue how that single Helvetica font managed to install itself there, because my Windows 7 installation is only a few weeks old and I am quite picky with what kind of software I install on my computer (I have a dual boot test installation for testing out stuff, so only very few programs actually make it onto my productive installation).

I'd recommend to copy the Helvetica font to a backup directory first, before deleting it. Just in case you need Helvetica some time in the future.

I also don't understand why Chrome can't fix that by themselves. IMHO it is stupid to use a BOLD ONLY font as the default font for displaying websites.

BTW: the reason why I looked for Helvetica in the first place was that in another place I found the tip to delete the following font from your system: Helvetica Neue Noir Italique

Since I didn't have that font, I just deleted the only Helvetica font on my system. It felt right, because it was called "bold" anyways. And it worked. All other tips like re-installing Arial or installing the European font fix didn't help at all in my case. I think Chrome developers actually produced a bug there.

1
  • That was exactly the issue on a client I used. Thanks a lot for your tip.
    – 2ndkauboy
    Commented Apr 9, 2015 at 11:50
0

I found that when using a mac, the problem wasn't with Chrome itself, but it was with the Font Book application. Since it was a public access computer, someone had gone in and disabled some fonts that Chrome used as default, one of which was every Arial variate except for Arial Bold Italic. When I re-enabled those fonts, Chrome promptly switched over to the standard font I had set (Arial Regular) in the settings menu. Hope this helps.

0

This is what I found that worked perfectly for me without formatting my PC: All you need is GImageX and your copy of Windows ISO.

Also, for deleting all the fonts and replacing them, I booted into Mini Windows XP in Hiren's BootCD. Windows 7 won't let me delete them because they are in use. Peace all.

1
  • 1
    Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Cfinley
    Commented Sep 18, 2014 at 19:31
0

Try to Install "Open Sans" Font from: https://www.google.com/fonts#UsePlace:use/Collection:Open+Sans

It worked for me. Install it and restart chrome.

Note: Later I uninstalled Open Sans fonts from the system and chrome continue working well (aparentely after recognise the font, it loads the fonts from the web, as it can see in developer tools, sources tab)

0

Copy the bold text, paste it in a text editor (I used OpenOffice Writer), click on the text and it will show what font it is (on the top panel). Then open Control Panel -> Appearance and Personalization -> Fonts, find the font and delete it. Done. For me it was Roboto font.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .