1

I had a problem last day when I was installing Windows 8 on my computer. In my harddisk, in this moment, I have 5 partitions:

  1. sda1: recovery data partition
  2. sda2: Windows 8 (NTFS)
  3. sda3: use for storage data (NTFS)
  4. sda4: extended partition unknown
  5. sda5: Linux swap

For more information or check details, you can see on : http://paste2.org/p/2646987

In the sda4 partition, I had a root partition (/) and a documents partition (/home): However, installing Windows 8, these two partitions have been converted into one partition unknown and I can't to go in.

I tried to use DiskInternals Linux-Reader but it can't check that because is "unknown", the filesystem is unknown, is no recognition of filesystem Linux.

I tried to use the tool "boot-repair" but the problem doesn't disappear (recommended solution).

I tried Super Grub Disk, but it isn't recognize any grub on my system.

Any suggestion of what would I do? Do you know any tool to recover any files on it?

I think solution is reinstall Linux but I'm going to lost my data.

2 Answers 2

0

Your extended partition sector start from 225,771,518 - 312,580,095. And your swap start at sector 307,802,112 and ends at 312,580,095. So, the rest of the sector from 225,773,537 - 307,802,112 should be your lost extended logical partition. You should be able to recover it with Gparted recovery tool. For further info on how to, follow this link. After you recover your partition table, you can mount via some sort of live cd and extract/backup your files.

1
  • thank you for the link. It helps me so much. With Gparted tool, i couldn't able to do it because, on that unallocated partition (extended), on menu "Partition", option "check" was not available but the others partition was ok... so i had to take "TestDisk" and write the partition table from extended partition.. It works!! However i couldn't mount it, said problems like fylesystem is not specified (fake !! --> I try this: mount -t ext4 /dev/sda5 /mnt --> it doesn't work)... so.. What could I do then? Opened "DiskInternals Linux Reader" program to recover where I wanted. Thank you so much. Dec 26, 2012 at 10:22
0

I want to add more information about this topic. The question that I ask is solved, but next, i have had troubles to recover my partition table. Gparted doesn't see my partitions recognized!! My partition table is corrupt. I mean, the extended partition that i had on my harddisk, was resize (I don't know how) and it occuped more bytes than harddisk let: partitions exceeded capacibility of my harddisk (you could see that because the simbol '+' appears on the right of the end sectors of the partition, and you could check that comparing number of sectors between total sector in your harddisk and number end sectors of the partition)

To solve this problem, and if anyone could be helpfull, get this link: https://askubuntu.com/questions/48717/how-to-manually-fix-a-partition-table.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.