2

Tried

http://www.imdb.com/find?q=%s
http://www.imdb.com/find?q=%s&s=all
http://www.imdb.com/find?s=all&q=%s

But when it loads the page, it loads http://www.imdb.com/find?s=all;q=%s (note the semicolon)

According to the search result page after a successful search, it should be: http://www.imdb.com/find?q=%s&s=all

2

I tried to reproduce your case. But when I do so, it worked for me.

  • My version: Chrome 23.0.1271.97
  • tools > settings > manage search engines
  • Added a new one with your first syntax http://www.imdb.com/find?q=%s
  • Selected a random movie name and searched for it via context menu
  • It found the correct search site on IMDB

Are you sure, you didn't messed up the syntax?

enter image description here

  • Hmm.. it would appear the problem was my shortcut.. set as i__ (for I space I guess) It will not work when set that way, and will not let me set it to just 'i' even though no other search engines are using that shortcut. I'll just go with im I guess – Damon Dec 26 '12 at 16:23
1

Open up your settings in Chrome and go to "Manage search engines...". Check to see if imdb is listed under "Default search settings". If it is, hover on it and click the X all the way over on the right. This should remove imdb from the list. If it is not listed under "Default search settings", see if it is listed under "Other search engines" down the page a bit. Again, remove imdb from this list if it is there.

Now, open up a new tab and go to imdb. Search anything in the usual way you would when visiting the site. Now go back to "Manage search engines". Imdb should show up under "Other search engines". Hover on it, and click "Make default". You've now enabled imdb as a shortcut, and it should have moved itself from "Other search engines" to "Default search settings" (the top one). The middle column should read "imdb.com". This is what you type into Chrome's omnibox (the address bar in chrome). Type "imdb.com" and hit tab and enter what you want to search for.

I prefer this method to trying to find or guess the search string because that is often version-specific.

For reference, I am using version: 29.0.1547.65 of Chrome

Note: Following the previous steps may make imdb your primary search engine (typing anything in the omnibox will search imdb) while also creating a shortcut. If you want to revert back to your favorite primary search engine, go to Settings -> Search, and change the value of the dropdown from IMDb back to whatever it was. Imdb should still be a shortcut.

0

I was having trouble, as well, so I just installed the iMDb extension I found in the Chrome app store. It worked perfectly!

Go to Google Chrome app store Search for iMDB Search Install app.

Good luck! Walt D in LV

Link as of 2018 was: https://chrome.google.com/webstore/detail/imdb-search/cbongpcdgehbfeajgkndgkbdkkfdmdik?hl=en

  • Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, merged into another one or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... – Donald Duck Mar 11 '17 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.