I'm not particularly experienced with Linux and I'm having some troubles which I'm hoping somebody can help me with. I've been trying to fix a stupid mistake I made for the last few days and have tried quite a few things with no success, so I'll just go over it and hopefully someone will notice something I missed or will have a suggestion about what to do next. Sorry for the long-winded story but I thought I might as well include everything.

My problems started when I tried to install Linux Mint 14 on my computer. I didn't have a USB drive available at the time, so I tried installing it directly to my hard drive using unetbootin and messed up somewhere along the way. I made a new partition on my hard drive, installed (or at least thought I did) a bootable copy of Mint there. When I restarted, the computer booted back into Windows, so I got the bright idea to change the active partition to the new one without considering that the installation might not have worked. Surprisingly enough it didn't install properly, so I got the bootmgr is missing error on startup as one might expect.

I just got home the other day which meant that I now had a USB drive available. My first thought was to transfer over Linux to the drive, use it as a Live CD and change the active partition back. I did this, setting the original Windows partition to have the boot flag using gparted, but when I restart and boot to my hard drive I still get the bootmgr is missing error. I haven't change the original Windows partition at all (to my knowledge) so I don't see why the Windows boot loader would have any problems.

My next thought was that maybe there is some problem setting flags from the Live CD, and that I might have to install Mint to my hard drive in order to properly change the flags. Since I had a USB I thought it would be easy, but I've run into a problem where the Mint installer hangs on a detecting filesystem step (or a similar message) indefinitely. I tried formatting the messed up partition (where I originally tried to install Mint) to ext4 and install it there, but I got a few warnings during the setup process about not being able to properly format it since it wanted to unmount the other partition. That partition has Windows 7 along with all my files on it, so I can't really afford to get rid of it.

At that point I was pretty frustrated and decided to pretty much start over. I actually just bought my first SSD and was planning on installing a fresh copy of Windows on it soon anyhow, so I saw this as an opportunity. My new plan was to install Windows 8 on the new SSD, back up the files I wanted from my previous Windows installation, format the entire old HDD, and then throw the backed up files onto the HDD again. This plan was sort of working, but now I have another problem. The HDD I'm using to back the files up is a pretty old external, 500GB drive that can't be formatted to anything other than NTFS, at least not using gparted. I have around 200GB of files that I want to transfer over, but after transferring 6GB I got an error saying the external drive was full. I did a bit of research on this, and after doing a quick check, I saw that the Inodes on the external drive were 90% used even though the drive is only 1% full. I don't know if this is a problem because the drive is NTFS or what, but it makes it so I can't really back anything up.

That's pretty much where I am now. At this point I'm not really sure what to do. I could try installing Windows 7/8 to my newer partition (not the one with all the files) and then try backing up through that since it might be able to deal with the NTFS drive better, but I don't really want to do this unless I have to. So if anyone has any information about what I've done already (how to do it properly pretty much) or any advice on where to go from here it would be much appreciated.

  • 2
    Gaaa... wall of text. – Nifle Dec 31 '12 at 13:05
  • Have you tried to do a standard "windows repair" installation? – Nifle Dec 31 '12 at 13:08

Your story makes some points clear although you did not spell them out: you are using the MBR/BIOS scheme (because of the concept of active partition), not GPT/UEFI; and your not-working active partition was created by Windows or a Windows-oriented tool, because the code in the boot record displays the message about "Bootmgr".

How do know you restored the correct Windows partition as active?

With Windows 7 and up, the installation creates two partitions while installing (if there are enough slots): one is a small "system partition", usually 100MB, where is stored Bootmgr and the BCD database store; the other is what will become the C: partition. The one to make active is the first one, not the second one.

Also, if you install Windows to another HD drive, even if another copy, make sure to also move the system partition, as determined by the system while booting, to the new drive; if you do not do it, the system will apparently work when the two drives are in the case, but will stop booting as soon as you unplug the drive where the system partition is located.

About the second part of your problems related with NTFS, I do not understand the problem: NTFS should automatically increase the size of the inode table (which is named MFT, and comes replicated as MFTmirr), assuming there is enough free space on the file system.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.