31

I just bought a new PC and the default installed OS is Windows 8. I want to install Windows 7 but when I go into the boot options screen I only have one option:

Windows Boot Manager

I can't find my DVD drive. It is plugged in and visible under SATA options. How is it that I don't see it in the boot options menu?

The weirdest thing is that the drive is working perfectly inside Windows. So Windows 8 can detect it but the BIOS can't? I'm stuck with Windows 8... Any ideas?

9
  • If I plug a usb key I see it in the boot options.
    – PhaDaPhunk
    Dec 27, 2012 at 0:37
  • 3
    PC model? Check the BIOS for an option to display/hide optical drives from the boot menu. Also look into options related to Legacy (BIOS) Mode, enabling the UEFI Compatibility Support Module (CSM) etc.
    – Karan
    Dec 27, 2012 at 0:46
  • @Karan The motherboard is Asus Uefi 0802 x64 // Computer Asus essentio series // Product model CM1855
    – PhaDaPhunk
    Dec 27, 2012 at 0:59
  • Also see comments and screenshots here for another Asus model. If nothing helps, you can always transfer Win7 Setup to a USB stick and install using that instead. As a bonus it will be much faster than installing from DVD.
    – Karan
    Dec 27, 2012 at 18:37
  • @karan It worked !! finally. I found a way to set it to legacy. it seems to cause more trouble now. I installed windows 7 but now windows doesnt detect m graphic card. I did all the updates, manually downloaded the latest driver for my radeon hd 7670 but its still undetected. I feel like setting things in legacy mode changed something that made my card un detectable. So i went into the bios and changed everything back to default. I does not boot anymore. I have to set everything to legacy for it to work.
    – PhaDaPhunk
    Dec 27, 2012 at 21:06

4 Answers 4

24

To get the DVD drive to show up in the boot menu, you might need to go into the BIOS (actually (U)EFI Settings) and enable Legacy (BIOS) Mode or the UEFI Compatibility Support Module (CSM) or similarly worded option:

1
(Screenshot of Asus Zenbook Prime UX31A-DH51 BIOS with CSM disabled.)

2
(Screenshot of Asus K55A BIOS with CSM enabled.)

Note: You might also have to disable both Boot / Fast Boot and Security / Secure Boot Control.

2
  • 6
    It's not clear and cost me quite some time - This solution works but after disabling the fast boot and secure boot and enabling the CSM you need to save and exit and enter BIOS again for the new options to appear.
    – immortal
    May 18, 2013 at 13:40
  • To see the DVD drive, you need to have the Launch PXE opROM enabled. Else, it won't work.
    – OuzoPower
    Jan 25, 2018 at 16:17
1

See my answer to THIS post. Try to change the UEFI boot options by "restarting" Windows8 while holding down the shift key, to enter advanced reboot menu.

0

The Asus VivoBook Max X541N is very hard to get to boot from USB or DVD.

I found only one way to make the system boot from a USB:

  1. Use the USB2 port, not the blue USB3 port.

  2. Turn off secure boot in the BIOS settings.

  3. Using Rufus, write the UEFI:NTFS as the Boot Selection option.  Do not select the ISO to burn, instead choose the UEFI:NTFS from the dropdown in Rufus, and burn that by pressing "START".

    rufus UEFI:NTFS image option

  4. Now, the USB will have two partitions; the empty bigger partition (that's actually writeable) is where you must copy the CONTENTS of the .iso file that you want to boot. (Not copying the .iso file, but copy and paste everything that is in the ISO file system onto the USB that you just wrote the UEFI:NTFS to).

  5. Now when you boot, it will load the UEFI:NTFS Rufus boot loader, which will then go and load the contents of the partition where you copied the file contents of the iso to.

This was the result of much testing, DVDs, MBR and GPT USB, every single setting; nothing would boot this laptop from USB or DVD.  Only this UEFI:NTFS partition type works a charm.

3
  • (1) It seems to me that the above answer is specific to USB drives, while this question is focused on DVDs.  It might be more appropriate to post this answer on the question that’s about USB drives.  (Also, this question is about booting / installing Windows 7, but your answer mentions Windows 10.) (2) Are you sure that you need to turn off secure boot in the BIOS settings and use UEFI? … (Cont’d) Nov 27, 2020 at 17:22
  • (Cont’d) … (3) Maybe I’m dumb, but I don’t entirely understand your instructions. (a) “Do not select the ISO to burn.” What, then? What should the user do? (b) “you must copy the CONTENTS of the .iso file …” Do you mean copy the file? If so, why yell the word “contents”? If you mean something other than “copy the file”, what, exactly, do you mean? (c) “… where you copied the files”. What files? You mentioned only one file. Nov 27, 2020 at 17:22
  • (1) try superuser.com/questions/477569/… (win 7 and win 10 things usually have same result) (2) Yes (3) I'll edit to make it clearer, thanks for feedback Nov 28, 2020 at 18:16
-2

Easiest option.... put the windows DVD into an external USB DVD drive... works fine without the mucking about.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.