I've two hard drives on my ThinkPad. One for dual boot of Windows 8 and Ubuntu (12.10) (it's separately installed, not with Wubi).

I've installed Dropbox on Win 8 and syncs all the folders into hard drive D: instead of the default location. Everything works fine.

Now, I am on Ubuntu. Same thing. I've installed the Dropbox. And I am trying to relocate the Dropbox default directory to the folders from hard drive D: . And it says

"The Target Folder is your Current Dropbox"


Any suggestions on how to solve this?


I haven't tried this but it should work. Try deleting the default Dropbox folder:

  1. Stop the Dropbox service
  2. Delete the default Dropbox folder

    rm -rf ~/Dropbox
  3. Link drive D: to the default folder (assuming D: is mounted at /mnt/D, change this to whatever you are using)

    ln -s /mnt/D ~/Dropbox
  4. Start the Dropbox service again.

It might still not work if Dropbox can detect that you are trying to sync the same folder to itself.

  • 5
    This could run into issues, because ntfs filesystem support for writing has been known to corrupt things.
    – yarbelk
    Dec 27 '12 at 11:23
  • 1
    @yarbelk, ntfs support has been stable for a while now, there used to be problems but most have been solved and ntfs support is now included in the mainline kernel.
    – terdon
    Dec 27 '12 at 13:39
  • 1
    @yarbelk Keep in mind, that in case you hibernate windows session and boot linux and write to NTFS drive, your files most likely would be lost (at least partially) because when you "unhibernate" Windows, it would still have hard drive write cashe in memory which would be flushed over hard drive and some files may be lost.
    – Dimitry K
    Dec 19 '15 at 15:04

Here is a solution that worked for me.

While in the "Select a folder" window enter the "Type a file name" button on the left (the one that looks like a pencil). From here you can write the path you would like to use instead. Ex:




You might check this answer:

`Change the Dropbox location from the installation wizard Some users experience the problem during setting-up Dropbox that they cannot select a Dropbox folder other than /home/username/Dropbox. In this case when the window for changing the path is shown , hit CTRL+L, enter the location (e.g. /mnt/data/Dropbox) and click on the 'Choose' or 'Open' button.'

From: https://wiki.archlinux.org/index.php/Dropbox#Change_the_Dropbox_location_from_the_installation_wizard

You'll need to delete to delete the whole dropbox folder first (see post by terdon), the Dropbox will select 'relink' when you restart Dropbox.


I had to

  1. Stop dropbox
  2. mv ~/Dropbox /stf/Dropbox
  3. ln -s /stf/Dropbox ~ # symlink new location into home folder
  4. rm -rf ~/.dropbox ~/.dropbox-dist
  5. run dropbox and relink device
  • not sure about step 4. In my case it has replaced the symlink with a fresh Dropbox directory. I believe that once DB has been set up, you should do steps 1-3, and step 4 is simply to restart DB Jul 3 '20 at 2:42

You can also try the following method first specify the location(parent directory) that you want to see and interact with the Dropbox folder (Desktop for instance). Then after linking Dropbox with your account click move Dropbox location and select the parent directory you want to have the Dropbox folder(Desktop in our particular example). After that quit Dropbox and delete the folder on the Desktop, as a last step create a symbolic link to the original Dropbox folder on the data partition on Windows and Ubuntu. I wrote this based on this tutorial.


After Dropbox is installed, click on the Dropbox icon (by default at the top right in Ubuntu 18.04), select Preferences, then Sync, and select the folder where you want your Dropbox files to be moved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.