20

I have a Dell N5110 laptop with integrated Nvidia GeForce GT 525M and an Intel HD Graphics 3000 card; My problem is the default card is the Intel one, and it provides a very bad performance with Windows 8. So can I force to use the Nvidia one all the time including "Desktop Windows Manager" ?

1
  • 2
    Depending on how you use your laptop, you may want to look for a solution that only uses the GeForce adapter for programs that actually need it. If you're not plugged in, the GeForce adapter drains your battery a lot faster than the Intel adapter. That's why so many laptops come with two adapters. Commented Dec 28, 2012 at 2:08

1 Answer 1

15

If you open your

  1. nvidia control panel
  2. Select manage 3d settings
  3. Global Settings tab
  4. switch the drop down from Auto to nvidia
  5. Reboot your computer

If you just want specific executables use the program settings tab and if it is not listed browse for it and add it.

Been messing with it on my machine and it seems to not allow you to switch for dwm.exe

7
  • 3
    I tried this many and many, but it doesn't. I also can't specify the dwm.exe in the nvidia control panel.... Commented Dec 28, 2012 at 11:48
  • It seems to work for all other non system files.
    – Phillip R.
    Commented Dec 28, 2012 at 13:01
  • Does the dwm really consume that much graphical resources under Win 8? Would an upgrade to windows 10 reduce that? We have a graphic designer at our company who has a windows 8 machine and problems with photoshop performance, thinking about upgrading him to an SSD, but i am searching for software solutions first.
    – Paul Weber
    Commented Feb 9, 2016 at 12:39
  • How about just disabling the Intel GPU in device manager? Commented Mar 10, 2016 at 9:54
  • @PaulWeber >"Would an upgrade to windows 10 reduce that?"< I'm on Windows 10 and DWM is still using a lot of GPU. Commented Feb 12, 2021 at 2:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .