I have a Dell Inspiron n5110 machine with Intel Celerino WiFi N1030.

Its been about two weeks I have started using Windows 8. Formerly, I was using Windows 7 Home premium in which I had no any problem. Yesterday morning, when I tried to connect my WiFi, I found a red cross in the WiFi bars. I thought it might have been disabled but it wasn't. Driver was installed and windows didn't find any problem with the driver and the adapter itself. I tried reinstalling the driver but it didn't work. Thought the adapter might be malfuntioning; booted Linux from USB and the adapter was detecting wireless networks. And lastly, I tried System Restore to the last time when it was working.

But Ethernet works well.

EDIT: I downloaded the latest driver from Intel for Windows 8 and installed WiFi connection utility. And the connection utility actually detects wireless networks but the network doesn't show up in Networks.

  • 2
    Is there an ON/OFF switch around the edge of the keyboard to toggle the WiFi? – j_bombay Dec 28 '12 at 20:31
  • There is. And an indicator as well.. :) – Dilip Raj Baral Dec 28 '12 at 20:34

You know the adaptor is fine because it works in another operating system. You also know the network is correctly configured on the modem/router end because you can connect okay via Ethernet. That means we are either looking at a physical problem or a configuration issue.

Physical problems with wireless cards are generally caused by poor reception. To check this try booting back into Linux and checking the strength of your wireless network by using a tool such as Stumbler (http://tools.meraki.com/stumbler). You would be surprised how often nuances in the driver code mean signal strength is sufficient in one operating system but not another.

As for configuration there are a number of things you can look at.

Start by going into Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings and check the wireless adaptor is enabled. This is a basic one and not likely to be the cause of your problem as the connection utility is detecting the network settings.

Failing that go into Device Manager. Find your wireless network card under "Network adaptors". Right click and go properties. There are quite a few things to check.

  1. In the general tab check the Device Status says "This device is working properly."

  2. In the advanced tab check the properties are correctly set. Most of these are tech jargon so be sure to use jargon. In particular look at power management properties and turn these off.

  3. Related to that last point untick all power management in the power management tab.

  4. Finally we come to the driver tab. In my experience this is where your problem will lie. The Intel Celerino WiFi N1030 for installing with the wrong drivers. I know you said you got the most up-to-date drivers but try getting them from Dell not Intel.

If none of the above works return to the list of network adaptors in device manager and check for duplicate devices. Be sure to enable showing hidden devices. In particular you are looking out for duplicate: Microsoft ISATAP Adapters, or Microsoft Virtual WiFI Miniport Adapters, or Wan Miniport Drivers.

One final pointer, I have experienced it in the past where this is caused by overheating not anything to do with drivers. If this becomes an intermittent problem try monitoring the temperature of your computer.

This is a comprehensive so if you follow my steps you will fix your problem. Good luck buddy!

  • The four points don't seem to be the problem. But what I suspect is under Network Adapters in Device Manager, I have three avast! Firewall NDIS Filter Miniport #44, #45 and #46 and about 100 UNKNWON DEVICE INSTALLED. – Dilip Raj Baral Dec 28 '12 at 22:26
  • Yes. Watch out for those miniports! – Brett Dec 29 '12 at 8:41
  • I guess Avast was the problem. I REFRESHED the PC and then disabled the Avast's Network Shield. Since then, I'm not having problem. – Dilip Raj Baral Jan 12 '13 at 19:31

Sometimes it could be the wifi adapter which needs resetting. In Win8, simply clicking on "trouble shoot problems" (after right clicking on the internet icon) does this resetting. I have similar problems with HP Laptops too.


Just remove your current wifi profile. For this go to start -control panel - network and internet- network & sharing centre - manage wireless networks - select your wifi profile - press remove Then press wifi signal on the task bar of your computer and reconnect. Thats all..


Have a Toshiba laptop with Windows 8.1 that mysteriously could not find wireless connections whereas our older laptop had no problem. Checked for airplane mode and no problem caused by inadvertently hitting the F12 key.

Eventually I happened to be in the 'Change Adapter Settings', double clicked on the Wireless Adapter that showed as 'Not Connected' and magically the wireless adapter was 'enabled'. I don't know how it got disabled but this may be worth a try for someone who has mysteriously lost the ability to detect network connections that are available.


I had similar problem where my adaptor did not detect wifi. I'm Using Windows 8.1. Tried almost every solution I can find from the net. The thing that worked out for me was to reinstall the driver of the wireless adapter that came with it.

At that time I was using D-Link DWA-132 Wireless N USB Adaptor(Rev.B). It had a Microsoft Driver of 15/5/2013 which did not detect the wireless network. I manually change back to the original D-Link driver that came with the adaptor which was a 28/09/2012 driver. It came back to life and detected the wifi.

Also for testing, I updated the driver using the recommended search by windows via net. It installed back the Microsoft driver and made the adaptor not detecting wifi again. So I rolled back to old one. So suspect is the Microsoft Driver no longer working properly with the adaptor. I'm not sure why but most probably something to do with Windows Update since before this I set my computer to autoupdate.


I had a similar problem and it was killing me! Finally, I randomly changed "Country Region" from Advanced tab from properties of my wireless card in the device manager and it worked! (If you did it and nothing happened, try restarting both laptop and router).

Country Region


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.