I'm trying to setup Remote Desktop on my computer. It's currently running Windows 7. RDP is set to allow for incoming connections.

I've followed the instructions at PortForward.com, but am having no luck. Here's the details:

Router: TP-LINK WR841N -- WanIP=, LanIP=
                          DHCP Bounds = (start) through

Computer Static IP (Assigned) =

External IP (whatsmyip.com) = 111.67.xxx.xxx

Also of note, I have port 3389 forwarded on the router to IP and it is enabled for all protocols.

Now when I run PFPortCheck, I get "Could not test port 3389 because some other application has that port locked. Please close any applications that may be using this port and try again."

Now this is funny, as I have removed all antivirus and firewall software from my computer, and disabled Windows Defender.

So, I run "netstat -aon" and I get the following:


PID 1216 doesn't show in Task Manager, but using "tasklist" from the command line reveals that it's svchost.exe. So I killed the process with "taskkill /PID 1216 /F" and it magically terminated.

Returning back to PFPortCheck, I try to test the port again. Only now I get "We were unable to ping your router" and "Your port is NOT OPEN or not reachable!".

So, can anyone tell me how I can open this port so I can walk accross the street and RDP into it?



  • Can you connect locally? Like from another computer in your LAN?
    – barlop
    Dec 29, 2012 at 14:43
  • What is the subnet mask for your WAN, and what is the subnet mask for your LAN?
    – barlop
    Dec 29, 2012 at 14:47
  • WAN subnet = / LAN subnet =
    – user182622
    Dec 29, 2012 at 15:06
  • Haven't had any luck connecting locally either, really not even sure how to try
    – user182622
    Dec 29, 2012 at 15:07
  • 1
    A)You must succeed in connecting locally before considering the router. B)Your network's IPS are both overly complex, and the subnet masks don't match them either. A way of fixing your IPS, is make your computer's static ip 192.168.0.zzz And your DHCP 192.168.0.aaa to 192.168.0.bbb (where aaa is less than bbb). Then your subnet mask can be At the moment given your LAN IP, Computer's IP, and LAN subnet mask, your computer's IP is not on your network so you'll have problems.
    – barlop
    Dec 29, 2012 at 22:24

3 Answers 3


I'm pretty sure the process that's locking 3389 is RDP itself. If you disable remote connections first and test again it should be able to test successfully, at least that's how it worked for me.

  1. Control Panel > System > Remote Connections
  2. Disable remote connections and Apply.
  3. Test again with port checker, could take a minute for RDP to release the port
  4. After you have your results you can re-enable remote connections and Apply

This should at least narrow it down for you, currently I have the ports test successfully after disabling RDP. Not sure what the rest of the problem is.


Your ISP could be blocking port forwarding depending on your package. The solution would be to upgrade your package. Ref: Is my ISP blocking ports? There are other work-arounds; ref: How can I have a server even if my ISP blocks incoming requests to my IP?


It's quite possible that Windows Firewall is interfering.

Open the Windows Firewall MMC snap-in (wf.msc in either the run box or Start search box), click Inbound Rules, and find the following rules: windows firewall - inbound rules

The group of 5 rules should be green-ticked. It's likely you don't need the TCP-WS-In/TCP-WSS-In rules, but I enable them anyway for completeness.

If they're not green-ticked, select all 5, right-click, then Enable Rule. Try to RDP in again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy