I have a few different VPNs I need to connect to. I'm using windows 8 and standard ptpp VPN. Every VPN I have created though results in the same error:

Error 720: A connection to the remote computer could not be established You might need to change the network settings for this connection

The VPN works in Windows 7 and XP. I'm not sure if this has something to do with my new laptop or if its something with Windows 8 itself. Any help would be greatly appreciated and if there is any extra info I can provide please let me know.

I've tried with virus scanner turned off and windows firewall turned off as well and I still receive the same error message.

  • Needs more details. A lot more details. And may be more suitable for SuperUser anyhow... doesn't seem like it's a professional admin problem, at least as described. Dec 29, 2012 at 0:40
  • thanks HopelssN00b, I'm not sure what info to provide that will be most helpful, if you let me know what info you need I can try and provide it. I'm happy to move to super user if that will be more appropriate.
    – campo
    Dec 29, 2012 at 1:13
  • I don't know either, but look at what you have provided us - basically that a bunch of your PTPP VPNs throw a 720 error when you use Windows 8. Uh, alright, but that doesn't have any information that's going to be much good for troubleshooting. Dec 29, 2012 at 1:22

8 Answers 8


Got this problem after migrating from Windows 8 to Windows 8.1. It was due to altered miniports which had to be reinstalled.

Here is how I managed to do so:

  1. Locate broken miniports [yellow icon]: Device Manager -> View -> Show hidden devices. I had for example 3 bad miniports: WAN Miniport (IP), WAN Miniport (IPv6) and WAN Miniport (Network Monitor).
  2. Regedit -> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4d36e972-e325-11ce-bfc1-08002be10318} -> Export. In the generated .reg file, locate the broken miniports. You will then identify all the subkeys which need to be deleted [for example in my case, subkeys 0039, 0041 and 0042]. Double check that those subkeys has a "DriverDesc" which matches our broken miniports... And delete those subkeys.
  3. Go back in Device Manager, and right click on a broken miniport, then "Update Driver Software" -> "Browse my computer" -> "Let me pick driver from a list" -> uncheck "Show compatible hardware" and wait for drivers listing generation... Then pick the first "Microsoft" drivers listed [BlueTooth Personal], and ignore warnings. The broken and undeletable miniport will then become a fake bluetooth card, which you will be able to delete.
  4. Repeat point 3 for all broken miniports.
  5. And reboot the system. The OS will create again its miniports from scratch.
  • This worked for me - though step 2 wasn't necessary. Uninstalling the 'Bluetooth Personal' driver had the same effect. Nov 11, 2014 at 0:55
  • If you have WAN Miniport (Network Monitor) delete it first Aug 10, 2015 at 14:55
  • 1
    I used a similar method with Windows 10 to Windows 10 Anniversary update. I just removed all the WanMiniport items, restarted, connected to the L2TP vpn and it was all good. It is also a good idea to update your NIC drivers after this update BTW.
    – AnthonyJ
    Dec 1, 2016 at 22:22
  • What if I don't see any yellow warning icons on any Miniport drivers in the device manager, not even after enabling "Show hidden drivers"? Jul 20, 2017 at 8:08
  • 1
    Just uninstall the broken miniports in Device Manager and then Rescan for Hardware changes and they'll come back automatically (healthy this time).
    – Mister_Tom
    Nov 7, 2018 at 21:42

It is caused by broken WAN miniports install (You can see yellow exclamation mark next to the WAN Miniport devices in Device manager). I created simple tool which uninstalls all WAN miniports and installs them again, so VPN and Dial-up connections work again. You can find it at Wan miniport repair tool

  • I had no yellow markers but this tool worked on Windows 10 Pro
    – 27k1
    Dec 6, 2016 at 14:04
  • +1 this worked for me on a "seemingly" clean Windows 10 install with no broken miniports Dec 27, 2016 at 17:48
  • Thanks bro. Windows 10 Pro, no yellow exclamation marks on WAN miniports. Used repair tool version 2 (took about 15 minutes), then Wan miniport installer and it's finally working.
    – poss
    Mar 4, 2017 at 10:31
  • Did not work. Now my Windows 10 returns BSoD every time I put it in sleep mode.
    – Eduardo M
    Jul 7, 2020 at 0:27

It might not be the issue with your VPN but with VPN server. It's possible that your IP address is out of the incoming IP address range defined on the VPN server

  • Go to Network and Sharing Center -> Change Adapter Settings
  • Right-click Incoming Connections, and then Properties
  • Click on the Networking tab and double click on the Internet Protocol Version 4 (TCP/IPv4)
  • Click the Specify IP addresses and change/expand an IP range so that include the IPs of your devices, or just change IP addresses on your machines to fit the already defined range

enter image description here

If that was the issue, your VPN should work


To make VPN work & fix broken / yellow warning WAN miniport's (virtual devices created by local services)

Stop Local service "Remote Access Connection Manager" & set to manual

Now in device manager miniports should disappear (if not you can update driver to "Generic Mobile Bandwidth adapter" or something like this when unchecking compatible hardware @ driver installation, then when it installs wrong device it should be uninstallable)

Next get devcon.exe from Microsoft (Driver Development Kit)

Then run:

devcon.exe install c:\windows\inf\netrasa.inf <hardwareId>

With each of these
<hardwareId> = 
MS_SstpMiniport (this is depending on Secure Socket Tunnelling Service, so make sure it is stopped)

Then you will have "Unknown device" in Device manager

Then Restart PC

Start service "Remote Access Connection Manager"

Now you should be able to connect VPN with working miniports (it is not necessary to have all miniports working, but just those required to specific VPN type of connection)


What the solution ended up being for me was a bad driver. Windows 8.1 installed a generic Broadcom driver on my PC. After going to Dell's support site and updating the driver to one that was specific to my laptop, the VPN worked without issue. I would guess that this would be the same for other brands.


That sounds to me like a driver or WinSocks issue. A few things to try:

NOTE: these are generally safe to try so long as you know how to install system drivers. If you don't want to risk loosing your network connection completely you probably shouldn't run these without consulting IT Support.

  1. Reset WinSocks using netsh. This handy command is Microsoft's way of cleaning out the networking pipes and often fixes issues caused by corruption or bad Antivirus software. Run it in a console as an administrator and then restart the computer.

    netsh int ip reset reset.txt

  2. Disable/Remove network drivers and re-install them. This is a bit more trial and error, but basically you would uninstall any VPN software you are using (and remove any existing VPN connections), then uninstall the networking adapters in device manager that you think are causing the issue, and then let it re-install them. MOST network adapters use built in drivers and are safe to remove (again... MOST not ALL, so this is where you are likely to run into issues if you haven't done this before). Once the network drivers are back you would re-install the VPN software or re setup the VPN connection in Windows.

Here is a picture of the adapters on my Windows 8.1 Workstation. You can see I have disabled the bluetooth, USB, and VirtualBox adapters that I'm not using, but if you are still having issues you can try uninstalling the WAN drivers and then use the Action -> Scan for hardware changes option to try and reinstalls them. It may not detect some of them until you remove and re-add you VPN connection.

Network Adapter

And if all else fails... see if there as another way to connect to the VPN. Some companies have multiple VPNs (Cisco and Windows, etc) or multiple VPN endpoints (East coast, West coast, etc). You can also look at setting up the VPN on your home router (Advanced routers often support VPN connections) or using a dedicated VPN device like the Cisco Meraki Z1


I tried all proposed solutions on Windows 8.1, but they only got me further into trouble. I ended up with a large number of irremovable WAN Miniport devices. I could only get out of that mess by manually editing the registry.

  • Download PSTools by SysInternals
  • Run regedit with psexec

    psexec -i -s -d regedit.exe
  • Warning: Backup registry keys before modifying them using Export function of Registry Editor

  • Search HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ROOT and delete any subkey with "WAN Miniport" in FriendlyName
  • Search HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4d36e972-e325-11ce-bfc1-08002be10318} and also delete any subkey with "WAN Miniport" in DriverDesc
  • Reboot machine
  • Windows should recreate WAN Miniport devices. If it doesn't, use WAN Miniport installer by Jaromir Kuba
  • Should warn the user to backup their registry before edits.
    – albal
    Aug 11, 2015 at 6:50
  • @albal Added a warning. But one probably wouldn't be in this trouble if they didn't ignore that warning in the first place. ;) Aug 11, 2015 at 9:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .