My aunt gave me a 3TB Seagate external USB drive for Christmas. It takes a little jiggling (power cycle) to work on my Mac, where it shows up as a perfectly functional NTFS partition, but in Windows 7, it doesn't even show up in Device Manager. If it showed up there, and in diskpart, I'd have no trouble getting it to work as a removable drive in Windows. But alas, Device Manager doesn't show it.

The drive did show up once in Device Manager, with a yellow exclamation mark. When I connected the drive, Windows raised a system tray balloon error about the device failing to update the driver. I tried manually updating the driver, as well as uninstalling the driver and repeating from scratch, to no avail. Now the Seagate doesn't show up at all in Device Manager.

TL;DR. The Seagate white LED is on. The drive functions as an NTFS partition in Mac, but in Windows, it doesn't even show up in the Windows Device Manager.


  • I tried rebooting. Didn't help.
  • I tried showing hidden devices in Device Manager. Didn't help.
  • I tried deleting all USB devices in Device Manager and then rebooting. Didn't help.
  • I tried unplugging the Seagate drive completely. Didn't help, though it was necessary to work with my Mac.

Google searches don't yield good results; most USB drive problems are easily fixed with diskpart -> select volume ABC -> assign letter=X, so 95% of Google results are that.

However, one tutorial suggested malware may be hiding USB drives. I'm installing Avast and checking if this is the problem.

Also, a tutorial recommended using a Windows installation disc to repair Windows, which would fix any corrupted USB drivers. The Asus laptop didn't come with a Windows disc but fortunately I was able to find one.


  • Seagate FreeAgent GoFlex Desk 3TB (PN: 9ZQ2P6-500 3 TB, though the Seagate website refuses to recognize the number in order to search for driver downloads)
  • Windows 7 Home SP1 x64
  • Asus A5SE laptop

Yet another tutorial suggests disabling the automatically turn off USB devices to save power setting. Effecting this change, then replugging in the Seagate drive finally fixed it for me!

  • Great but strange... :) – Viral Jain Dec 31 '12 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.