When I search for files under Libraries or any of its subdirectories, no results are returned. Here is a screenshot demonstrating the problem: Screenshot of search for * in Libraries

Here is a screenshot showing the current search settings in Folder Options: Search tab in Folder Options showing my settings

Here is a screenshot showing my indexing settings values: Screenshot of indexing options

Here are some things I have already tried:

  • There are files present.
  • Windows Search service is running.
  • The search query is OK.
  • Searching in other places still works.
  • Searching in the folders that are mapped to the library folders (such as C:\Users\username\Documents) still works.
  • The built-in Find and fix problems with Windows Search tool did not find any problems.
  • I've tried enabling Always search file names and contents.

How can I get Windows Search to work correctly for Libraries?

  • I don't get any results for * (star) on it's own. What if you try *.pdf or *.txt or *.doc?
    – Guy Thomas
    Dec 31, 2012 at 10:45
  • Apparently searching in all folders of a Library should work, but it's failing for me as well in Win7.
    – Karan
    Dec 31, 2012 at 22:44
  • @GuyThomas, '*' works fine for me in other locations. I've tried other valid queries such as the ones you suggested, but it still doesn't work.
    – Sam
    Jan 3, 2013 at 10:26

1 Answer 1


I no longer experience this problem in Windows 8.1 now that libraries have now been moved under This PC. Since it's a free upgrade for Windows 8 users, I think upgrading is an acceptable solution.

Search results in Documents showing files

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.