I'm trying to install Ubuntu on a wiped drive and for some reason when i choose the install option, it goes to the BusyBox built in shell. Can anyone tell me why it would do that and how to get to the regular install?

  • What version of Ubuntu? – John T Oct 8 '09 at 5:39
  • Ubuntu version 9.04 – The.Anti.9 Oct 8 '09 at 5:45

this is probably because i'm not using sata drives, i'm using IDE drives

I faced this problem quite some time ago ( on a normal system) - Used this workaround

At the LiveCD initial boot screen:

  • Select F6 for more options
  • Add the following option to the beginning of the options list: break=top
  • Press enter to start booting. Ubuntu will start booting, but kick you out to a command prompt
  • At the prompt type these two commands: modprobe piix & exit
  • You will now boot into the LiveCD normally

Thanks to UbuntuForums, I had this delicious'd

  • I tried this and it says all the mountings failed and "No init found". – The.Anti.9 Oct 8 '09 at 20:31
  • This worked for Ubuntu 12.04 on old hardware! – Jon Skarpeteig Oct 22 '13 at 10:52

This is almost always due to a fatal error during the boot process. Does this happen once you boot of a fresh install, or does it happen when booting from the live cd?

At first, the internet actually does not seem to be that helpful for this error. I kept getting the same problem a while back, and I never figured how to fix it. But alas, do not give up!

Assuming the live CD works, try booting from it and mount the 'broken' install as the root (where hda1 is the 'name' of the hard drive):

mkdir ~/Desktop/harddrive
sudo mount -rw /dev/hda1 ~/Desktop/harddrive
sudo chroot ~/Desktop/harddrive
sudo aptitude reinstall ubuntu-minimal

Hopefull, this will reinstall the base ubuntu system.

I also found this gem from the Ubuntu 9.04 release notes:

Boot failures on systems with Intel D945 motherboards

Users have reported slower than normal detection of SATA hard drives on systems with Intel D945 motherboards in Ubuntu 9.04. This may cause the system to drop to a busybox initramfs shell on boot with a "Gave up waiting for root device." error. Wait a minute or two and then exit the initramfs shell by typing exit. Booting should proceed normally. If it doesn't, wait a bit longer and try again. Once the system boots, edit /boot/grub/menu.lst and add rootdelay=90 to the kernel stanza for your current kernel. (Bug 290153)

  • unfortunately the live cd does the same thing. brings me to the same place :( – The.Anti.9 Oct 8 '09 at 6:08
  • thanks for the update. unfortunately this does not work either. it errors when i type exit. this is probably because i'm not using sata drives, i'm using IDE drives. – The.Anti.9 Oct 8 '09 at 6:18
  • Have you ever had Ubuntu working on your computer? It may just be a simple case of incompatible hardware, so you just might not be able to use Ubuntu... – Josh Hunt Oct 8 '09 at 6:29
  • No this is a computer i just put together from a bunch of parts i had laying around. I guess i'll look into another distro. – The.Anti.9 Oct 8 '09 at 23:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.