My question is similar to this. But none of the posted solutions worked.
my.ini file is pasted here. 'mysql.log' is pasted here.

The problem seems to be caused for no reason. I don't remember changing anything specifically.
Apache runs fine. I'm on windows 7 x64.

Most interestingly, mysql.exe runs just fine. No password is on. mysqld.exe doesn't run
(running it through console will just cause an infinite delay)

What I've tried

  • Turning off Firewall
  • Checking port 3306 to be open
  • Checking running services for other instances of MySQL
  • Checking for other installed versions of MySQL
  • Changing password in my.ini
  • Running wampserver as administrator
  • Disabling SQL Server services
  • Uncommenting 'skip-networking' option
  • Switching my computer's networking mode to DMZ (just in case if router firewall issue)
  • Googling and trying every other suggested solution
  • Re-installing wampserver
  • Restarting PC

I don't know what to do anymore. Anyone has a solution?


Search for mysql-bin.index file, delete it, then restart MySQL.

  • there was no such socket file in my temp folder :/ I've edited the post and added the log file (it has some stuff about InnoDB...)
    – jzeus
    Dec 31 '12 at 10:33
  • Search for mysql-bin.index file, delete it, then restart MySQL.
    – alex_m
    Dec 31 '12 at 19:09
  • YES THANK YOU! IT WORKS NOW! I can't believe it was as simple as that. Please move it to your answer for future reference.
    – jzeus
    Dec 31 '12 at 23:35

In my case the problem was I had moved the mysql folder from my old system and replaced it on the new system, luckily I had backed up the freshly installed mysql. Reverting it worked


Please check the port that mySql is using on your system then change the port number of wamp servers mySql service to that number by entering it in my.ini for Windows last line restart service and it immediately turns green. Hope this helps because I ran into similar problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.