6

I have a SanDisk Cruzer 32gb flash drive that cannot be read only on a specific computer due to some unknown reason. Do note that all my other flash drives are working fine on this computer. Here's my situation...

Background Info

I recently bought a HP laptop. Before wiping the laptop's hard disk, I used HP recovery media creator to store the HP recovery image in my flash drive. After I was done with wiping my laptop's hard disk and making sure my clean installation of the operating system works, I wiped my flash drive with the standard Windows formatting utility. I don't like the OEM's recovery stuffs because of all the bloatware, but I backed it up to my flash drive just in case my clean installation fails.

The Problem

Now, this flash drive cannot be read on my main desktop (running Windows 8) anymore. However, the same flash drive can be read on my other two computers (also running Windows 8) perfectly fine.

Observations:

  • The flash drive cannot be accessed in Windows Explorer or any Explorer alternatives.
  • Received "Windows can't access this disk" error messages when trying to check the disk's filesystem.
  • The flash drive's size cannot be viewed in My Computer.

Ironically, according to the Device Manager, the USB flash drive is detected and working fine.

Things I've Tried

  • Uninstalling the USB mass storage driver and rebooting.
  • Uninstalling all USB drivers and rebooting.
  • Wiping and reformatting my flash drive on the computers that it can work on using MiniTool Partition Wizard.
  • Using BootIce to rewrite the MBR of the flash drive.
  • Copying the MBR of my other flash drives to the problem flash drive using BootIce.
  • I've also tried formatting in FAT16, FAT32 and NTFS.

All of the above methods have failed. Does anyone know what's the problem, or have encountered such errors before? Please enlighten me. Your help is much appreciated.

Thank you. =)

  • What shows in the Disk Manager? What do you mean by "trying to check the disk's filesystem"? – David Schwartz Dec 31 '12 at 19:48
  • The flash drive shows up in Disk Management with no partitions. And I meant you can check the disk's filesystem using the Windows built-in tool under Properties > Tools > Error-checking. Do note, MiniTool Partition Wizard's surface test in another computer works fine with no errors. And the partition shows up in other computers as well. – Roy Jan 1 '13 at 5:10
1

I've had this exact issue but never got it resolved; The work around (as I was not able to fix it) was to copy the data to another flash drive!

  • Did you use HP recovery media creator as well? I think it did something to the first few sectors of the flash drive. – Roy Jan 1 '13 at 5:14
  • Actually, no. I did nothing clever with it, other than buy it from a shop, put on a few music files from another machine and then tried to read it from my machine and no luck; I guess it could be how the drive was formatted but, nothing I tried worked sadly (hence my work around). Sorry I didn't have a 'real' solution to help. – Dave Jan 1 '13 at 8:58
1

I had a similar issue before and this is what i did to resolve.

Open Device Manager and then plug in the drive.

  • Device Manager was blinking when the drive was plugged in, so something was recognizing it. However, no additional disk device was appearing.

  • Looking in the "Universal Serial Bus Controllers" section in Device Manager, there was a "Mass Storage" driver loaded. Other USB drives when plugged in would load a "USB Mass Storage Device" driver for a moment before that disappearing and the additional disk device then appearing.

  • I right clicked and uninstalled the apparently erroneously loaded/associated/cached "Mass Storage" driver. When the drive was reconnected the proper "USB Mass Storage Device" driver then loaded and it started working again.

I think the cause of it was removing the device while Windows was still loading the drivers for it. Sometimes Windows takes a while to fully recognize a device (USB devices can have "subdevices" which require a chain of drivers to be scanned/loaded) and if this process is interrupted it may remember the wrong driver for the device.

protected by Community Apr 15 '17 at 6:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.