I have had my laptop for a month now, and had no problems.

I recently got a mouse to go with my laptop in order to play games. However, ever since I started using this mouse, all of the gestures have completely stopped working. Whether the mouse is plugged in or not, all of my gestures are gone, even the most simple ones.

Is there anyway to fix this?

  • The same happened to me with my Asus Zenbook after wake up. The solution below works
    – Kostanos
    Jun 5, 2014 at 18:25

4 Answers 4


I have an Asus UX32VD and have the same problem. If it's the same software, ASUS Smart Gesture, this might work for you as well. Do either manual or script. I'm lazy so I have a runnable script since this problem seems to occur more often than I'd like (a couple of times per week).

Manual Method

  • Open task manager, locate the process "Asus Smart Gesture Center"; End the task.

Script Method

  • Script: Create a .bat-file somewhere with the following code:
    Taskkill /IM AsusTPCenter.exe /F

When you run the bat-file, it will kill the process.

Both: when ending the task it seems like the other Asus processes running will detect it and start it, enabling multi-finger touch again.

To make the batch file:

  1. Open Notepad and copy/past this command: Taskkill /IM AsusTPCenter.exe /F
  2. Then click Save As and type in .bat (remove .txt)
  3. Change the drop down list to All files . and click Save

That's it! When ever the problem appears, just double click the file and it will fix it!

  • Brilliant. It worked for me.
    – homaxto
    May 2, 2013 at 16:38
  • Wow, the Microsoft forms can't even come up with a solution other than: Update drivers and/or restart. Thanks Teknokraten!
    – Gary
    Sep 9, 2013 at 13:49
  • Worked on my Asus Zenbook UX21A. Thanks!
    – tangens
    May 9, 2015 at 7:06

I have the same problem with my vivobook. When using external mouse, touchpad gestures stop working. There seems to be no solid solution to this according to fast googling.

This happens when ASUS Smart gestures goes off for some reason. There is a folder inside ASUS install folder C:\Program Files (x86)\ASUS\ASUS Smart Gesture, but none of these programs actually restart the processes for Smart Gesture. By restarting windows WITHOUT exernal mouse plugged, I got the processes working again and there seems to be several of them related to Smart Gesture.

This is not a desired solution of course, but at least it's possible to get gestures on somehow.


try opening "Asus smart gesture" then on the bottom right corner of the screen find it double click in it and on the mouse detection tab, uncheck "disable gestures when mouse plugged in".


If you have an Asus laptop, then the solution is as follows:

  1. Go to support.asus.com from IE (for some reason Google Chrome doesn't work with Asus' website).
  2. Let the website automatically search for your laptop's model number. After it checks for the latest Java version (very important), it'll find your correct model number.
  3. Enter the OS you have (I had Windows 8). It should bring up all of the latest drivers in chronlogical order.
  4. Select the driver that is malfunctioning on your laptop, e.g. smart gestures and download it.
  5. Install it by unzipping the .rar or whatever file was downloaded and running its setup file and/or deleting your existing, crappy driver first from Control Panel → Add or Remove Programs.
  6. Reboot after being prompted or after the new install is completed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .