The Trash icon on my Dock shows the Trash containing files. I tried right-clicking and Empty Trash, but it still shows files there.

When I open the Trash folder in Finder, I can see several files still there.

I tried manually emptying the Trash with rm ~/.Trash/*, but that doesn't work. In fact, ls ~/.Trash/ shows the folder being empty!

I tried Force Quitting Finder, but that didn't help either.

I'm sure rebooting would fix the problem, but I'd prefer a solution that didn't require rebooting.


  • Mac OS X 10.8.2 Mountain Lion
  • MacBook Pro mid-2009
  • 1
    did you try logout and login?
    – John Siu
    Jan 3, 2013 at 3:01
  • @JohnSiu I've got programs running that I'd rather not kill. Upvote nevertheless. :)
    – mcandre
    Jan 3, 2013 at 4:26
  • Try restart spotlight(OS X indexing service).
    – John Siu
    Jan 3, 2013 at 4:49
  • Are the ghost files on another volume? Files moved to the trash from the startup volume go in ~/.Trash; files on other volumes go in /Volumes/<volume name>/.Trashes/<your user ID #>/ instead. Jan 3, 2013 at 18:29

4 Answers 4


Rebooting doesn't help. I used Disk Utility.app to try to repair the USB drive. It turns out the file system is corrupted; only backing up my files, reformatting, and restoring my files fixes the .Trashes folder on the drive.

The Seagate also forcibly disconnects when the cable is jiggled; Hardware issues likely caused the file system corruption in the first place.


If a file is IN-use while you trashed the app from finder, the trash won't delete it so quit the app then try again..

edit: try holding option key while emptying the trash

if thats not working try:

Open a terminal.
cd .Trash
rm -fr . (or rm -fr * )

Open Disk Utilities

Repair permissions

read this: as i had this problem so long ago

and to solve it I did something that you'd never think would solve the problem, but for some reason it did. I opened up the trash, did a Cmd-A to select all, then a Cmd-I to find out how (collectively) big all of these files were and when my Mac tried to access the files to see their size, they disappeared

maybe its worked for you ;) let me know

  • I repeat, variations of rm does not fix the problem; ls doesn't even show any files being in .Trash.
    – mcandre
    Jan 3, 2013 at 16:48
  • do you try Super Empty Trash?I would suggeste restarting, personally. Or relaunching Finder
    – Arash
    Jan 3, 2013 at 17:26
  • Restarting Finder doesn't help.
    – mcandre
    Jan 4, 2013 at 15:07

Are these trash items by chance from an external drive? Or a backup? If so, try:

cd /Volumes ls cd <> ls -a sudo rm -rf .Trashes

  • Can you give an explanation on how that command works? Two line answers are generally not a good format for SU. Oct 22, 2013 at 14:48

Does not require rebooting? Here how it's done.

There are multiple trash in the system. Even your external has it's own '.Trash' directory. Hence, some lock folders from other disk may not be able to be deleted even with the 'option' key is pressed.

Then how?

  1. Go to your common trash finder on desktop
  2. Right click the stubborn file/folder -> 'Get Info'
  3. Under 'General', take note or copy the 'where' path
  4. open terminal [command+space, type "terminal"]
  6. It will ask to override... type y for yes and enter.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.