I’m stuck.

I had rdc working and connecting just fine sometime before the holidays and now I can’t seem to get it to work within my network at home (never mind from work-I also can’t do that but could a couple of weeks ago). I’ve tried to troubleshoot it and I just can’t seem to figure out where the error is. Here is what I have tried/checked:

  • I can see my desktop (ideal target) from my laptop. It is visible under network devices, I can browse files from laptop to desktop and vice versa. I can ping the desktop from the laptop with both the ip and the device name.
  • My laptop is on the wireless and the desktop is plugged directly into the router but plugging the laptop in too did not make a difference.
  • Both computers are assigned a dhcp reservation and when asked, both computers report the ip listed in the reservation.
  • Yes, rdc connection is enabled on both computers.
  • The desktop only has windows firewall running. Yes, the remote desktop exception is checked. I tried disabling windows firewall altogether; that didn’t fix it either. I also tried disabling the firewall on my laptop too just for fun and it also made no difference.
  • AP isolation is disabled by default on my router and always has been (and still is).
  • The port used by the rdc is still what I set it at in the registry.
  • I changed the timezone settings off of the correct time zone and then then changed it back on my router; it made no difference (although, this did fix a similar issue about two years ago…)
  • The time zones for the computers are the same.
  • The desktop is Win 7 ultimate and the laptop is Win 7 pro (it may be something stupid I’m missing but it isn’t that)
  • I restarted my router (I really don’t want to reset it but it may come to that…)
  • Of course I’ve restarted the machines several times.
  • I reinstalled the network drivers (yeah, now I’m just trying random stuff-I recognize this)

The only significant thing I changed during the holidays was a couple of days ago I tried an in-place upgrade to Win 8 (yeah, I know…but I like playing with a new os). There were driver conflicts and after 3 or 4 failed attempts I gave up in favor of getting something done with the return to work this week. That may have caused something but it may not have been working before that. I only use RDC in sudden bursts of good work ethic.

So…that is the end of my story. Any suggestions?

And just for completion, my router is the Linksys E3000

Followup: I formatted my machine and installed windows 8 fresh and I still cannot connect. Perhaps the problem is with something on my router? Anyone have any ideas?

  • 1
    Here is some FAQ's for RDC: RDC FAQ's Do you have the capability to use another laptop/desktop besides the one you have and see if you're running into the same problem? – Christopher Chipps Jan 4 '13 at 4:00
  • Yeah, I think I've covered all the points in the RDC FAQs. Do you see one I missed? And yes, other desktops also cannot connect to the target desktop but can ping and browse files on it. – RdcUser Jan 4 '13 at 5:16

I'm blaming the aborted Windows 8 upgrade. Your computer SAYS that remote desktop is enabled, but I'll bet it isn't. I hate to say it, but I think you're going to end up reinstalling Windows. Hope I'm wrong.

  • Could be. I checked my fDenyTSConnections value in my registry and it seems ok. – RdcUser Jan 4 '13 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.