It seems like Windows XP doesn't recognize default icons of many applications in my old Dell machine e.g. Skype, Windows Live Messenger, Adobe Reader, Microsoft Office 2003. Though I can open all those applications, the most annoying part is that all files associated with them don't have icons too and I cannot get their types by glancing at their icons. Is there a way to fix this without reinstalling Windows and all softwares?

FYI I have tried TweakUI and cleared icon cache but it didn't work.

  • did you reboot after clearing the icon cache? Have you tried safe mode to fix it? – brandstaetter Oct 8 '09 at 15:02
  • I rebooted but it didn't work still. Did you mean I should try clearing the icon cache in safe mode? – puri Oct 8 '09 at 15:12
  • Yes, maybe that works? I think it's worth a try. – brandstaetter Oct 8 '09 at 15:33
  • No, it still doesn't work. Thanks anyway. – puri Oct 9 '09 at 3:55
  • Several years down the line...but if this is still affecting you, see the answer to this question: (superuser.com/questions/1065358/…). – AlainD Apr 14 '16 at 16:17

You can delete the Iconcache.db file in the application data location and restart machine to fix the corrupted Windows XP icons. It will rebuild it while reboot.

default location of Iconcache.dbis in (hidden file)

C:\Documents and Settings\<username>\Local Settings\Application Data

| improve this answer | |
  • This has not helped me with the same issue, but I know several people on forums report this working. – AlainD Apr 14 '16 at 14:40

You always can try the repair installation option that most installers have. They will restore the icons and the registry associations.

| improve this answer | |

Try to restore the default association for ico files you can find a reg file that do this here

| improve this answer | |
  • I will try this as soon as I can put my hands on that machine. Hope it works. Thanks in advance. – puri Oct 9 '09 at 18:42
  • Tried it but didn't work still. – puri Oct 12 '09 at 3:24

Changing your desktop colour depth and then changing it back again (i.e. 32-bit to 24-bit and back) should also rebuild them.

| improve this answer | |
  • I have tried that too. But it didn't work. Thanks anyway. – puri Oct 9 '09 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.