4

Possible Duplicate:
Files with illegal filenames

Under Win7, since 2 weeks, somehow a new folder with three dots D:\...\ was created, but i can't access it, delete it, not even rename it, it tells me that some application is using it.

I installed a Unlocker 1.9 app, no luck, instead it removes ownership from all folder on my disk drive D:, instead of removing a folder with 3 dots, beach. Now i should restore it one by one. Disk D: is on Raid 0, (2x1TB WD Caviar Black).

Now, after using unlocker, i can access (but not delete) that folder, which inside is the same content as in root of disk D:

here is a pic:

enter image description here

thanks for any advice

1
  • 1
    Sorry for commenting on this old post, but I ended up with exact the same problem (three dot folder, files seemed to be mirrored from the root folder). I even had a three dot folder recursively inside. I managed to delete it using the GitBash on Windows 10 with rm -rf 'path'. Thanks to @bruno as well for the solution.
    – bene-we
    Dec 2 '20 at 15:57
7

You just created an invalid path or your path was somehow corrupted. The problem with the folder is that it's not able to have dots at the end of it.

In this case, we have to tell to Windows to ignore some special reserved names and remove that folder away. Sadly, we can't see the contents folder by a Microsoft Windows product, you'd have to boot on a Linux live CD or something like that to do it.

Happily, we can remove all the contents of the folder and so delete it without exit of the confort of our old friendly system :) Just open the prompt and write the commands:

rmdir /Q /S \\?\c:\path-to-invalid-folder\folder-name\

**Change the "c" letter to your drive letter, folder-name to "..." and so forth...*

Hit enter.

PS: BE CAREFUL WITH THIS COMMAND. It will remove all the contents of a folder and so on. So, if you write it wrong, like "\?\c:\", you'll lose your system.

5
  • thanks for info, will try it. the main problem is that i dont know how but it let me to enter that folder, and inside that folder is everything same as in the root. so i hope it wont remove everything from that disk.. if so, i will be in deep sh*t... Jan 5 '13 at 13:14
  • I tried here and worked fine with a non-root directory. So you probably will have no problems with it. Maybe Windows is misspelling it and thinking that the folder's name is "\" instead of "\..." A funny hack indeed ;)
    – bruno
    Jan 5 '13 at 13:52
  • Since the OP said that the ... folder has "the same content as in root of disk D:" I would be very wary of deleting its contents.
    – martineau
    Jan 5 '13 at 15:14
  • Fortunately, I have a HDD that the files doesn't matter for me. So I did it and nothing happened, so you can do it without fear.
    – bruno
    Jan 5 '13 at 17:20
  • i installed a Take Ownership registry plugin which let takes ownership of permissions, because after using that tool "Unlocker", it closed all folders in disk D:... now i can access this directory: `D:/...(same content as in root)/...(empty folder)/ Jan 5 '13 at 17:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.