Router: Linksys WRT-54G-TM DD-WRT Version: DD-WRT v24-sp2 (08/12/10) mega

When I go to NAT/ QoS => Port Forwarding, the list is empty. I previously had port forwards set there, and they are still actually working, so I'm guessing that it's just a display bug.

I suspect the display issue might be because of low nvram. I cleared the ttraf data, but it's still very low (size: 32095 bytes (673 left)). I've also tried lowering the maximum ports, TCP timeout, and UDP timeout values and rebooted the router, but the nvram is still low.

I haven't tried a hard reset yet because I've set a lot of configurations over the years and I don't remember all of them. If I could resolve the display issue without doing a hard reset, I can take a screenshot of each page, and then perform a hard reset and re-configure.

Any ideas on how I could resolve this would be great.

  • Post this in the DD-WRT forum (dd-wrt.com/phpBB2), you're not going to get help here. Also make sure you read the wiki for your device and the announcements on the forum. – dtech Jan 7 '13 at 23:28
  • 1
    @dtech Why are you so certain the OP won't get help here? This is a valid question, and although we might not have a huge audience for DD-WRT questions, this certainly doesn't need to be closed. – slhck Jan 8 '13 at 9:05
  • Because this is not a configuration problem but a bug in DD-WRT or issue with DD-WRT. It's unlikely that people with sufficient knowledge are here to solve it. It would be another matter if it was a general configuration problem e.g. "how do I connect two DD-WRT routers wirelessly" – dtech Jan 8 '13 at 12:40

The issue is that the NVRAM is full, so you need to delete some content. Preferably the history of the WAN traffic. On newer DD-WRT there is a delete button, but on older ones like v24 SP1, there is no GUI for this.

You can solve this by doing the following:

  1. Login with SSH to the router
  2. nvram show | grep traff

This will list you all the traffic variables. Eg: traff-05-2013 means the data from May, 2013. If you want to keep them, just copy to excel or notepad

Delete 1-2 year's data with:

  1. nvram unset traff-05-2013
  2. Repeat step 3 with all the traff-* variables you want to delete
  3. nvram commit to save the changes.

After this the list of the port forward will be empty, but now you just have to press the Add button as many times as many port forwards were set, they will show up in the list.

  • I had the same problem and this was exactly what I needed to fix it. Thanks! – Nick Meyer Mar 3 '15 at 3:18

I have the same problem (WRT54GL, DD-WRT v24-sp1 (07/27/08) std) and also needed to free some nvram memory. When the memory is not full, I can force ddwrt to display the forwarded ports using the add button in the gui, multiple times.

As for the problem "can't remember all settings". I downloaded all ddwrt settings by logging in with putty, turning on the log file and issuing nvram show. Then I have the settings in my local file, I can sort it and review. Through nvram command it's also possible to change the router settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.