I had an issue with Skype couple of day ago (no login cells, only background with clouds and rainbow); according to some how-to I erased all private content and history + restarted IE to default setting ans that solved my problem with Skype login, but google maps problem still remain.

Normal view: https://dl.dropbox.com/u/10341727/StackExchange/SU/IE10-Default.jpg Compatibility view: https://dl.dropbox.com/u/10341727/StackExchange/SU/IE10-Compact.jpg

I can't see maps even in compatibility mode :/ And not only on google maps website, all websites containing javascript. In setting I'm pretty sure that I did all what I could and set all active scripting, javasctipt + activeX to "Enable".

regsvr32 jscript.dll give me msg that operation ended OK but nothing happen in IE.

Normally I'm using Opera & Chrome but I have to use couple of applications which require explorer and javascript features such as SketchUp geolocation window or Bitdefender to log into my account.

You should be able to see world map, the same map and controls as on google maps website: https://dl.dropbox.com/u/10341727/StackExchange/SU/SketchupAddGeo.jpg

I can log in: https://dl.dropbox.com/u/10341727/StackExchange/SU/BitDefLog.jpg but after that I can't grant request: https://dl.dropbox.com/u/10341727/StackExchange/SU/BitDefLogError.jpg

Interesting is that google recommend to have the latest version of flash but

1) I can't download it: https://dl.dropbox.com/u/10341727/StackExchange/SU/GetFlashError.jpg
2) IE should have some kind of flash by default buy youtube doesn't work and
3) If I download the latest flash for IE, I can start installer but nothing happen and there is no active process with "flash" in name :] But that is not so important as javascript features.

I used to have McAffe Internet Security bloatware for couple of days (automatically shipped with new Asus laptop) but now I'm using Bitdefender Internet Security software and I'm not sure if this problem can be somehow connected with what kind of security SW you have.

I have and use another browsers but sometimes I have use feature which is connected with IE and that I'm lost. Any help or idea is more than welcome :]

OS: Windows 8 64bit
IE 10.0.9200.16466 (regularly updated)

1 Answer 1


I have Windows 8 Pro 64-bits, and maps work properly, so I assure you it's not an issue with IE 10 itself. At least, not in the design. Maybe try the modern UI version of IE 10. Better?

Perhaps your installation of Internet Explorer got corrupted somehow. You could try to remove it, with all its add-ons, and reinstall it.

It could be your Internet Security program. Try disabling it completely and browsing to Google Maps and whatnot.

Alternatively, look into the settings in IE. Maybe your privacy settings are too high, and websites are all confused because it they're not allowed XYZ. Maybe try to turn off the Do Not Track option, if it's on.

  • I'm not sure if you can completely uninstall IE10 from Win8 because in update history is "explorer" missing (there is no line with IE in name at all). Anyway I've tried to disable/enable all addons in IE, restarted to default settings, disable whole IE in system and re-enable it again but behavior is still the same. I have also changed all privacy setting to low or custom and enable all scripting plus added google domain into trusted sites. I can disable whole internet security at startup but it doesn't help.
    – San-Tus
    Jan 7, 2013 at 8:56
  • Well, removing all Internet Explorer folders should do the job just fine. Then you can surely reinstall it from Windows Update and/or the Microsoft website.
    – Ariane
    Jan 7, 2013 at 9:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .