I have a printer driver which I'm trying to install on a Windows XP workstation. The installer runs, then suddenly crashes. I can find no error dialog or log file or system event record to tell me what happened.

What steps can I take to diagnose this crash?

The installer is for the Brother MFC-8860DN Windows XP Printer Driver.

It arrives as a single file MFC-8860DN-inst-D2-enus.EXE. This is a self-extracting archive. The file's description (from its properties) is "ZIP SELFEXTRACT". The copyright is "Copyright (C) A.I.SOFT,INC. 1996-2003". When I run this archive, it creates a directory tree mflpro\ in the same directory. As near as I can tell, the self-extracting part runs fine. It displays a message about running mflpro\Setup8860DN\Usa\Setup.exe, and then dialogs, apparently from that setup.exe, appear.

Directory tree mflpro\ has a subdirectory mflpro\Setup8860DN\Usa\ containing Setup.exe and BRINST.INI. The file's description (from its properties) is "Launch integrated installer". The copyright is "Copyright © 2005 Brother Industries, Ltd." File version is Interestingly, I don't see anything in this setup.exe or the accompanying BRINST.INI file which says Installshield, or gives an obvious hint about how to get diagnostics.

If I cd to that directory, then run that Setup.exe, I see the InstallShield dialog sequence I saw when running the original self-extracting archive, followed by the crash. But I don't see any diagnostics on the command line window, or any log file written to that subdirectory.

I've looked in all the Event Viewer categories (Application, System, etc.) and there are no event records associated with this installer and its run.

Are there any ways to get diagnostics from this installer, without having access to the source files from which the installer was built?

I'm looking for hints about why the install fails, hoping that I can correct those problems and let the install succeed. Plus, since InstallShield installers are widely used, if I know the tricks I can perhaps diagnose other problems in the future.

Flexera, the makers of InstallShield, have a consumers support site, but I didn't see anything there which was helpful. I'm contacting the support department of the company that made the driver, but while that percolates, I'd like help becoming self-reliant, i.e. "learning how to fish".


(I'm sorry. This is far from a full answer, but the comments are too short, and it's a huge pain that you can't add a line break.)

I get a feeling you might be digging a bit too far into this. To begin with, if their installer is indeed buggy, it's not your responsibility, and probably not within your power, to fix it, looking into IntallShield and all. You should tell them about it, instead.

Perhaps you did these already, but in case you forgot something, here are the basic things to do when such an issue arises:

  • Check whether you have the right installer. This file is for Windows Xp Home and Professional 32 bits. It's the right thing for you, right?

  • Delete everything and re-download. Something might have been corrupted somehow in the download.

  • Make sure the folder in which you're working has all the rights required to read/write files and all. To make sure, try to work in a place where there's never any restriction, such as My Documents.

  • Try running things as administrator.

  • Make sure the driver hasn't been installed already. Who knows, sometimes we're so focused on finding the issue that we don't see there's no issue. Not to insult you. Something like this has happened to me in the past. Frustrating. There's a chance the installer isn't so well coded, and when it's already installed, instead of telling you, it just stops execution abruptly.

  • Make sure no security program, antivirus, firewall, etc. is messing with you.

If really, you can't find the issue, maybe their installer is just messed up and they need to remake it. Even huge companies make mistakes. And Windows Xp being really old, there's a chance they didn't get a report for the issue yet. In that case, it would be nice to inform them of the issue. And if the installer is -not- messed up, well, perhaps they can tell you why it's not working for you.

You could try a driver updating software to work around this issue of the installer that bugs. http://alternativeto.net/software/driver-genius/ Here.

Perhaps I misunderstood your issue. What do you mean by "created a directory tree"? Isn't a directory tree a way of displaying directories? How do you create a directory tree if not by opening the file explorer and asking for it?

Also, I don't find very clear what happens. It would be a great help if you could give screenshots of the steps you've performed. Maybe I totally misunderstood. "An image is worth a thousand words".

Finally, why do you "cd" to a directory? Why are you in the command prompt? I must have missed something. People who make software expect people to run it by double-clicking on the file/icon/whatever. I wouldn't be surprised if using a command prompt for some obscure reason would cause issues. The maker wouldn't even know it, because I seriously doubt this is in their list of things to test.


EDIT: I tried to post with images, but it does not allow me to becuase of "new spam prevention policies" and days I need to get 10 rep to do so. I can email the corresponding images so you can see what I am talking about. EDIT#2: Thanks Jim for upvoting, I have added the pictures.

I am having this EXACT same issue. You execute the .exe (in my case in the USA folder) and the installer launches, then crashes.

To explain more technically, see the image below. The 8860inst.exe extracts and creates the directories DATA and Setup8860DN. At the end of the extraction, you are asked if you would like to launch the Setup.exe in Setup8860DN\USA\Setup.exe. At this point the install shield wizard loads, finishes, then launches the install shield wizard. Setup Folder Structure

Then you see this screen for a couple seconds: Install Wizard

Then it disappears. No Windows application error, nothing in the installer log. Interestingly enough, we have another machine, exact same make and model, same Windows XP and service pack, and it installs with no problem. Very, VERY frustrating.

I have tried multiple downloads of the software, multiple different versions from different sources, all to no avail.

  • Thank you for your helpful answer. I've upvoted it. Perhaps now you have 11 rep, and can edit this answer to include the images. – Jim DeLaHunt Jan 24 '13 at 6:06

I'm looking for hints about why the install fails, hoping that I can correct those problems and let the install succeed.

Take a look at Procmon from Microsoft (Sysinternals). It will allow you to trace to activities of the installer and might give you a clue as to what's happening at the time of the crash.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.