I've been trying today to figure out how to make an Ubuntu box wake on lan. The computer is pretty old, but I found the WOL option in BIOS (I also enabled wake up on pci). The network card is ADMTek NC100 Network Everywhere (revision 11). From what I've read on the net, it should also support WOL.

First, I tried with ethtool, but because of the fact that the NIC's driver is tulip, ethtool does not give me any info about it.

ethtool eth0
Settings for eth0:
No data available

ethtool -i eth0
driver: tulip
version: 1.1.15
bus-info: 0000:02:0c.0

The command I first tried to use was:

ethtool -s eth0 wol g

but it didn't work (because of tulip, I guess).

Next, I tried to modify /proc/acpi/wakeup. The initial state was:

Device  S-state   Status   Sysfs node
SBTN      S4    *enabled
PCI1      S4     disabled  pci:0000:00:1e.0
UAR1      S4     disabled  pnp:00:08
USB       S4     disabled  pci:0000:00:1f.2
USB2      S4     disabled  pci:0000:00:1f.4
AC9       S4     disabled
SMB       S4     disabled  pci:0000:00:1f.3

so i tried to enable the PCI for wakeup (even though it wasn't my ethernet card's slot) by doing this:

grep 'PCI1.*enabled' < /proc/acpi/wakeup >/dev/null || \
echo PCI1 > /proc/acpi/wakeup

After the command is run, the PCI port is listed there as enabled, but WOL still doesn't work. I've tried it by using this client for Windows XP. I haven't tested to see if it sends the magic package ok, but it was among the first in Google search and there were references for it all around, so I don't think that the problem comes from here.

I've ran out of ideas (and out of forums to search :) so I hope someone here has figured out a solution for this issue. Thanks :).


Maybe a shot in the dark here, but could it be your router blocking the port required for the magic packet? (port 7 I believe)

I've tried to do something similar in the past, whilst at Uni I would WOL my PC at home (so I could ssh files over for backup of uni work etc). One problem I had was my router at home blocking that port, once I opened it up and forwarded all traffic on port 7 to that PC it worked fine

Hope this helps

| improve this answer | |
  • Nope, I've already set port forwarding on my router. Also, this would only matter if I were trying WOL from the internet. Right now I'm trying it from the LAN. Thanks for the answer though :). – Alex Ciminian Oct 22 '09 at 10:16

Here is a patch to enable WoL on your card.

Intended for an Ubuntu 8.04.3 LTS with kernel version 2.6.24, it may require some tweaking...

On my box with Ubuntu 9.10 karmic installed (but different ethernet card/driver than yours), I had to add this in /etc/rc.local, before exit=0 :

ethtool -s eth0 wol g

Otherwise the ethernet card is disabled at shutdown, preventing it to receive the magic packets.

WakeOnLAN typically use UDP port 0, 7 or 9.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.